Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using ssh (WinSCP) to transfer some files from a server to my workstation.

The problem is that at some files I get disconnected. Always same files. I am the owner of the directory so I guess the file permissions is not a problem. (Also I set the permissions to 777). Is there a size limit or something like that?

Protocol is SFTP, server is 32bit machine. Files are 100MB tops.


Worked with Filezilla using ftp. This temporarily fix the problem but is not exactly a solution since maybe next time I won't have root access to create a ftp account

share|improve this question
Some more information you should include: What is the target operating system (also 32/64 bit)? How large are the files? What protocol are you using in WinSCP (It supports SFTP, SCP and SSH connections)? – Kyle Smith Jun 23 '11 at 14:21
You have enough free space right? – Chopper3 Jun 23 '11 at 14:34
For setting read permissions for yourself, it is sufficient to do u+r on the file. You create potential problems by setting stuff 777. Don't. – wzzrd Jun 23 '11 at 14:34
Edited, added all u asked. – zozo Jun 23 '11 at 14:37
what version of winSCP are you using? I've had similar issues with 4.x. Try an older winSCP version. – sreimer Jun 23 '11 at 14:58
up vote 1 down vote accepted

Some options:

Try one problem file on its own

Try using another client (FileZilla?)

Try via a command line ?

share|improve this answer
Worked with filezilla using ftp. This temporarily fix the problem but is not exactly a solution since maybe next time I won't have root access to create a ftp account. – zozo Jun 23 '11 at 14:51
what about using filezilla with sftp? – Jure1873 Jun 23 '11 at 16:46
Yeah, what @Jure1873 said. FileZilla does SFTP just fine. – Will Martin Jun 23 '11 at 20:04

Are the files that you get disconnected on quite large ? Perhaps you need to configure keepalive in winscp. In the Login Dialog->Connection Section turn keepalives on by selecting one of the options. The default 30s should be sufficient for the time between keepalives.

share|improve this answer
I tried... same problem. The files are not large... are larger than the rest but not so large. – zozo Jun 23 '11 at 14:38

Can you use another program than WinSCP for testing and set debugging / verbose mode on? Or maybe WinSCP has that too. It might give you good information about why the connection was dropped.

share|improve this answer
Any suggestion about what I should use? – zozo Jun 23 '11 at 14:45
pscp? From here: – wzzrd Jun 23 '11 at 14:49

Is this transfer going through a Firewall or Intrusion Prevention device? They can easily cut connections based on flaky signatures, weird flags, etc. it's also possible a Antivirus scanner could pull off the same thing.

share|improve this answer
Nothing like that... I guess is size related as most ppl suggested... but 100MB is quite small. – zozo Jun 24 '11 at 9:31

I would compress the files into a tar ball. And then transfer just the one file across. It will be a lot quicker. Then SSH into the target server, and uncompressed it.

share|improve this answer
I get error if I try to copy the tar. – zozo Jun 23 '11 at 14:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.