Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting increasingly frustrated with XenServer. Currently I'm using 5.6FP1 and it seems to be very fragile. Canceling any VDI-related action almost guarantees trouble.

This time I tried to create a new VM using a snapshot for a template, with the fast disk cloning option disabled. It would take much longer than I was able and willing to keep my XenCenter open, so I canceled it. That took ages too, so I had to decide to "Quit Anyway."

Since, I seem unable to create any new VDI. New attempts at cloning halt with "The attempt to clone the VDI failed," and creating new VMs based on built-in templates hang at "Provisioning."

I'm in need of some advice how to solve this. What I did so far is run a xe vdi-list, which returned nothing odd to me, but I'm no expert. I assume that an incomplete VDI is blocking my Storage Repository somehow, however, how to deal with that remains unclear.

share|improve this question
    
"guarantees trouble" how? Anything in the logs? top? Is the problem consistently reproducible? Anything show up if you do a file system check? –  Bart Silverstrim Jun 24 '11 at 1:08
    
@BartSilverstrim I've had several XenServer problems before, mostly under similar circumstances. That was with a previous version on an older server, though, so I thought it might be related to that, but now it appears not to be. Back then the filesystem was OK, and since my problem is solved, I'll have to assume it is now too, because I can't take the server offline for checking. –  thoiz_vd Jun 24 '11 at 16:32
add comment

1 Answer

up vote 1 down vote accepted

Have you treied xe-toolstack-restart? I have seen this issue in the past with my infrastructure. Also, have you looked at xen cloud platform? It is based on xensrver 5.6 fp1.

share|improve this answer
1  
That command had the faulty VDIs show up under Local storage, so I could delete them. Thank you for that. Unfortunately I can't change platform, because my hosting provider does not support it. –  thoiz_vd Jun 24 '11 at 16:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.