Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Our MySQL server seems to be using a lot of memory.

I've tried looking for slow queries and queries with no index and have halved the peak CPU usage and Apache memory usage but the MySQL memory stays constantly at 2.2GB (~51% of available memory on the server).

Here's the graph from Plesk. Running top in the SSH window shows the same figures.

enter image description here

Does anyone have any ideas on why the memory usage is constant like this and not peaks and troughs with usage of the app?

Here's the output of the MySQL Tuning Primer script:

        -- MYSQL PERFORMANCE TUNING PRIMER --
             - By: Matthew Montgomery -

MySQL Version 5.0.77-log x86_64

Uptime = 1 days 14 hrs 4 min 21 sec
Avg. qps = 22
Total Questions = 3059456
Threads Connected = 13

Warning: Server has not been running for at least 48hrs.
It may not be safe to use these recommendations

To find out more information on how each of these
runtime variables effects performance visit:
http://dev.mysql.com/doc/refman/5.0/en/server-system-variables.html
Visit http://www.mysql.com/products/enterprise/advisors.html
for info about MySQL's Enterprise Monitoring and Advisory Service

SLOW QUERIES
The slow query log is enabled.
Current long_query_time = 1 sec.
You have 6 out of 3059477 that take longer than 1 sec. to complete
Your long_query_time seems to be fine

BINARY UPDATE LOG
The binary update log is NOT enabled.
You will not be able to do point in time recovery
See http://dev.mysql.com/doc/refman/5.0/en/point-in-time-recovery.html

WORKER THREADS
Current thread_cache_size = 0
Current threads_cached = 0
Current threads_per_sec = 2
Historic threads_per_sec = 0
Threads created per/sec are overrunning threads cached
You should raise thread_cache_size

MAX CONNECTIONS
Current max_connections = 100
Current threads_connected = 14
Historic max_used_connections = 20
The number of used connections is 20% of the configured maximum.
Your max_connections variable seems to be fine.

INNODB STATUS
Current InnoDB index space = 6 M
Current InnoDB data space = 18 M
Current InnoDB buffer pool free = 0 %
Current innodb_buffer_pool_size = 8 M
Depending on how much space your innodb indexes take up it may be safe
to increase this value to up to 2 / 3 of total system memory

MEMORY USAGE
Max Memory Ever Allocated : 2.07 G
Configured Max Per-thread Buffers : 274 M
Configured Max Global Buffers : 2.01 G
Configured Max Memory Limit : 2.28 G
Physical Memory : 3.84 G
Max memory limit seem to be within acceptable norms

KEY BUFFER
Current MyISAM index space = 4 M
Current key_buffer_size = 7 M
Key cache miss rate is 1 : 40
Key buffer free ratio = 81 %
Your key_buffer_size seems to be fine

QUERY CACHE
Query cache is supported but not enabled
Perhaps you should set the query_cache_size

SORT OPERATIONS
Current sort_buffer_size = 2 M
Current read_rnd_buffer_size = 256 K
Sort buffer seems to be fine

JOINS
Current join_buffer_size = 132.00 K
You have had 16 queries where a join could not use an index properly
You should enable "log-queries-not-using-indexes"
Then look for non indexed joins in the slow query log.
If you are unable to optimize your queries you may want to increase your
join_buffer_size to accommodate larger joins in one pass.

Note! This script will still suggest raising the join_buffer_size when
ANY joins not using indexes are found.

OPEN FILES LIMIT
Current open_files_limit = 1024 files
The open_files_limit should typically be set to at least 2x-3x
that of table_cache if you have heavy MyISAM usage.
Your open_files_limit value seems to be fine

TABLE CACHE
Current table_cache value = 64 tables
You have a total of 426 tables
You have 64 open tables.
Current table_cache hit rate is 1%
, while 100% of your table cache is in use
You should probably increase your table_cache

TEMP TABLES
Current max_heap_table_size = 16 M
Current tmp_table_size = 32 M
Of 15134 temp tables, 9% were created on disk
Effective in-memory tmp_table_size is limited to max_heap_table_size.
Created disk tmp tables ratio seems fine

TABLE SCANS
Current read_buffer_size = 128 K
Current table scan ratio = 2915 : 1
read_buffer_size seems to be fine

TABLE LOCKING
Current Lock Wait ratio = 1 : 142213
Your table locking seems to be fine

The app is a facebook game with about 50-100 concurrent users.

Thanks, Rob

share|improve this question
6  
first rule of diagnosing memory 'problems' - is it actually a problem. You want all your memory used, because you paid for it, so applications tend to use it for caching. Are you suffering any issues, or is mysql just using memory because it's free. It's probably constant because it's much more efficient for mysql to do that than request and release memory all the time. –  EightBitTony Jun 25 '11 at 13:50
add comment

2 Answers

MySQL uses a lot of memory on purpose-- more memory = less disk access = better performance. the constancy of the usage is likely due to table cache, key cache, and query cache. If you want it to use less, you can tune the parameters in your my.conf file; just beware that it may slow down if you take memory away.

Take a look at http://hackmysql.com/mysqlreport ; you may be able to get some helpful information there about tuning it without performance loss.

share|improve this answer
1  
I found that the innodb_log_buffer_size was set to 2G. According the MySQL manual this should be between 2 and 8MB.. The database is only 17MB in total. The usage is now down to about 150MB and the performance is better... –  Rob Stevenson-Leggett Jun 29 '11 at 9:43
    
Wow--good find; that sounds like a typo. –  Bryan Agee Jun 29 '11 at 15:17
add comment

For general optimizations, try mysqltuner: https://raw.github.com/major/MySQLTuner-perl/master/mysqltuner.pl

share|improve this answer
    
mysqltuner is good at telling you when you've not got enough memory allocated for MySQL - not so good at telling you when the settings are too high. –  symcbean Sep 18 '13 at 22:19
    
It provides nice metrics view, so, it's still easy to adjust settings when you're working with default my.cnf, example: limit max. connections to 30 gives economy of ~100MB RAM with default my.cnf. –  GioMac Sep 18 '13 at 23:01
    
No - it highlights major bottlenecks in your config. If you want to get a summary of the state of the system for monitoring or for fine tuning, try hackmysql.com/mysqlreport (just noticed that this is what Bryan says too) –  symcbean Sep 19 '13 at 10:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.