Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have been handed a server that has a fresh installation of small business server 2003.

SharePoint has been installed, and it is a completely fresh copy (no changes made)

I know for a fact that everything was paid for so this isn't some dodgy copy.

When I try to click any option in any of the floating menu's in IE 8, the browser asks me if I want to debug .. Error: 'undefined' is null or not an object

for example, I got to Projects - and click on the sample project, then click delete on the floating menu that pops up and the error appears.

This is brand new, I cannot believe I am having this problem!

Has anyone come across this, is it an old problem with easy fix?

All windows updates installed - see no updates for sharepoint?

EDIT: This is WSS2 so I am going to upgrade to WSS3... http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=14117 http://www.techrepublic.com/article/installing-windows-sharepoint-services-30-on-windows-server-2003/6176833

Hopefully this will resolve the problem

share|improve this question

2 Answers 2

up vote 0 down vote accepted

wss2 was designed for ie6 which explains why the better browser breaks (thanks microsoft!) upgraded to wss3 and works amazingly. will accept this as my answer when SO allows (2 days)

share|improve this answer
    
Did any of the doom and gloom MS suggests might happen regarding CompanyWeb actually occur? –  Robert Kaucher Jun 27 '11 at 16:27

STOP RIGHT NOW!!!!! SBS 2003 is not the same as Server 2003. If you try a default upgrade from WSS2 you could destroy the SharePoint install.

http://technet.microsoft.com/en-us/library/cc671966(WS.10).aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.