Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As a trial run for a client I am trying to enable the "Lock Pages in Memory" setting on my development server, but no matter what I change, I cannot get the "Using locked pages for buffer pool" to show up in the SQL Server log. I want to make sure I can do this correctly before I do it for a client.

Our development server is a Windows 2003 with 4 GB of RAM, SQL Server 2008 R2 Standard Edition 32Bit.

Below is what I have attempted:

  • Checked "Use AWE to allocate memory".

  • Set the "Maximum server memory" setting.

  • Added startup parameter -T845 in the SQL Server service configuration.

  • The SQL Server service is running on the LocalSystem Account so from what I have read I do not need to enter an account in the "Lock Pages in Memory" priveledge. However, I did try changing the service to operate under the "Administrator" login, and added that login to the "Lock Pages in Memory" privelege.

  • Restarted SQL Server Service.

Nothing I have done will put

Using locked pages for buffer pool

into my SQL Server log, but the 845 trace appears to be turned on when I run DBCC TRACESTATUS.

Anyone have any ideas about why nothing I have done appears to turn this on?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Actually, it appears that Lock Pages in memory was working – I just didn't see it because was just looking for the wrong message in the SQL Server log. For 32bit systems the SQL Log message is not “Using locked pages for buffer pool”, it is “Address Windowing Extensions is enabled”.

I got this from “Marian” on the Database Administrators site:

Marian quotes another blog which I had read previously… but embarrassingly enough, I must have skipped over that critical piece of information.

share|improve this answer

In x86 you might also need to add the /PAE switch to boot.ini in order for SQL to use AWE.

See this TechNet article for more information on how to do that.

share|improve this answer
    
I think you this might be what I need. I will try it out and let you know. Thanks! –  Clinemi Jun 27 '11 at 20:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.