Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Have a Dell PowerEdge 2350 with dual nics built into the motherboard. eth0 works fine. Setting up an IP under eth1 results in the error: "SIOCSIFFLAGS: Resource or Device Busy".

I have two identical 2350s and get the same error on eth1 for both servers. The server OS is CentOS.

Help greatly appreciated.

share|improve this question
    
How are you setting up the IP? Through ip, ifconfig or netconfig script? –  Rilindo Jun 27 '11 at 20:46
    
Through config files in /etc/sysconfig/networking –  a coder Jun 27 '11 at 20:52
    
Can we get the output of ifcfg-eth0 as well as ifcfg-eth1? –  Rilindo Jun 28 '11 at 2:15
    
I'll work on that. IN the meanwhile.. ethtool eth0 returns just one line "Link status on". ethtool eth1 returns a full array of data on the nic. The same command on the sister server returns full data on both interfaces. –  a coder Jun 28 '11 at 13:16
    
so there is no interface set up on eth1. ifconfig eth1 returns standard mac address, rx/tx (packets 0 on each) but no IP. –  a coder Jun 28 '11 at 13:25

1 Answer 1

We suspect the problem was corruption after an unexpected power outage at the data center (the backups failed). The network config files were OK, however the drivers were clearly out of whack.. eth0 didn't exist, peth0 did, and eth1 had the problem stated in the original question.

The problem was ultimately solved by reinstalling the OS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.