Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to create a virtual machine(OS = Windows 7) with 2 displays on vSphere. VM has VMware Tools. I go to

Edit Virtual Machine Settings > Video Card > Maximum Number of Displays [2].

When I click ok. The configuration returns to Maximum number of displays = 1. what should I do to keep the change?

share|improve this question

migrated from stackoverflow.com Jun 27 '11 at 20:52

This question came from our site for professional and enthusiast programmers.

    
What OS is the VM running: Linux or Windows? Have you installed VMware Tools in the VM? –  Henk Jun 27 '11 at 21:22
1  
That might be by design as vSphere is not geared towards running desktop configurations. Good chance the setting is left there for VMware Workstation compatibility/interoperability. –  user48838 Jun 27 '11 at 22:09
1  
@user48838 - I couldn't disagree more, vSphere is more than capable of running oceans of desktops, in fact with shared memory it's easier than many other systems and v4 introduced support for multiple monitors. @Eduardo - have you increased the amount of video memory you've assigned to your VM? You can also set it to 'auto' too. –  Chopper3 Jun 28 '11 at 14:56
    
@chopper3 I have tried increasing the amount of video memory and tried 'auto' too. Nothing worked. And I really need this VM with 2 monitors. –  Eduardo Thiesen Jun 28 '11 at 16:09

1 Answer 1

-- Who would encounter this problem --

  • Anyone who are using "bare-metal" hypervisor such as vSphere ESXi which installs directly onto machine with no OS require.

-- Why this problem exists --

  • This is the strategy that VMware has been taken in order to separate the feature giving for VM access through:

    • vSphere Client's "Guest Console" for administration purpose (only single monitor), VS.,
    • VMware View for end user usage (support multiple monitors)
  • In fact not only multiple monitors, there are also lots of other features you see in Workstation, Player, ESX are locked away in vSphere Client.

-- Our goal --

  • Assuming vSphere Client is installed on a remote machine with dual monitors (each 1600x1200)
  • The following solution will make the vSphere Client's "Guest Console" to see a single monitor of one resolution (say 3000x1000), which is slightly less than the sum of 2 monitors, because we have to take into the account of the window of the "Guest Console".
  • It took me weeks to figure this out.

-- Solution --

  1. Make sure your "Guest Console" has the maximum setting for your video memory and resolution

    • Edit Virtual Machine Settings > on the top right corner make sure "Hardware version 7" is use
    • Edit Virtual Machine Settings > Hardware > Video Card > Memory required for displays > Enter total video RAM > 128
    • Edit Virtual Machine Settings > Options > General > Configuration Parameters... > click "Add Row" button to add the following parameters:
      • svga.autodetect => false
      • svga.maxHeight => 1200
      • svga.maxWidth => 3200
  2. Download the "latest VMware Tools" (e.g. "VMware-tools-windows-8.3.7-381511.iso") into you remote machine from:

  3. Install the "latest VMware Tools" into your Windows 7 in your "Guest Console"
    • first uninstall the "old/existing VMware Tools" in your Windows 7
    • in the "Guest Console" there is a "CD/DVD" button, click on it
    • select "Connect to ISO image on local disk"
    • select the "VMware-tools-windows-8.3.7-381511.iso" you have downloaded in step 2
    • begin install the VMware Tools to the Windows 7
    • upon completion restart your Windows 7
  4. Enable 2 displays/monitors in one VM
    • in the Windows 7, start the dos prompt
    • type in 'cd C:\Program Files\VMware\VMware Tools', press 'enter'
    • type in 'VMwareResolutionSet.exe 0 1 , 0 0 3000 1000' (you may replace the value 3000 and 1000 to a value less than the sum of your 2 displays/monitors' resolution), press 'enter'
    • now you will see your new screen resolution to 3000x1000
  5. To make the Windows 7's new screen resolution fit the "Guest Console"
    • goto the menu of the "Guest Console"
    • click on "View" > "Fit Window Now"
    • in some case you can freely change your "Guest Console" and click on "Fit Guest Now", this will change your Windows 7 resolution to fit the "Guest Console" window
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.