Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install APC (Alternative PHP Cache) on a CentOs dedicated server. I've everything done apart from configuring phpize. Running :yum -y install php-devel gives me the following error:

file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.1.57-1.el5.art.x86_64 conflicts with file from package mysql-5.0.77-4.el5_5.3.i386 etc etc for other languages

So, i think the MySQL version I have is too old & I more than likely need to upgrade mysql to version 5.1. Im reluctant to do this as a) its a live server (although only 3/4 domains) b) I've read I'll read to recompile PHP if I upgrade.

To add to this I have Plesk installed for managing domains & might need reinstalling/reconfiguring also.

Sorry for the long intro but it's my first post & best to give as much info as possible, so my question is basically,

Is there any way I can run :yum -y install php-devel to get phpize working to complete installation of APC for the version of MySQL I currently have installed? ie 5.0.77.

share|improve this question
    
Please add centos mysql 5.0.77 phpize apc tags –  Whiteyq Jun 28 '11 at 12:05

2 Answers 2

up vote 0 down vote accepted

There is a very good chance that APC is already in your yum repository which would allow you to install it without using phpize.

Try: yum install php-pecl-apc

(If it isn't in the default CentOS repository, try CentOSplus or EPEL if that is not an issue).

Edit: One more point of mention, it is unusual to get dependency problems if you are using a single repository - it sounds like you have multiple repositories enabled and might not be using the priorities plugin.

share|improve this answer
    
That worked a treat cyberx86, thanks ever so much. You saved me a lot of hardship, :)) –  Whiteyq Jul 5 '11 at 15:00

Why do you have mysql-libs-5.1.57-1.el5.art.x86_64 installed? Were you fooling around with a different repository?

Can you just yum remove mysql-libs? Then run from the APC directory:

phpize

configure --enable-apc

make && make install

and add (at minimum) extension="apc.so" to your /etc/php.ini

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.