Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had the Default Web Site running on localhost port 80 smoothly. I wanted to enable SSL on it so I first created a Self Signed Certificate in Server Certificates section of IIS Management Console.

Then I clicked on Edit Bindings option on the Default Web Site and Added https binding that uses my newly created certificate.

After that if I try to start the Web Site I get the following error:

"The process can not access the file because it is being used by another process."

What do I need to do to make it work? If I remove the ssl binding it starts working fine. I'm guessing it can't access the certificate file. What should I do to fix this?

I'm using Windows 7 Ultimate 32bit.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Try starting the server in HTTP only mode and have a look at the result of the following command:

netstat -an | find ":443" | find "LISTENING"

If that command doesn't return an empty list, it means you have already something bound to 0.0.0.0:443 You can then use the netstat -anb command to find out which process is using that resource. What to do afterward depends on what process you find.

share|improve this answer
    
Skype was eating up 443 port so IIS couldn't listen on it. –  Hasan Khan Jun 28 '11 at 14:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.