Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

By default the example Solr application included with version 1.4.1 takes two minutes to process documents sent to the index. I've seen other servers configured to take 3+ minutes. Where can you change change this to zero or 15 seconds?

share|improve this question

You need to adjust autocommit option in your solrconfig.xml. By default its:

<autoCommit> 
  <maxDocs>2000</maxDocs>
  <maxTime>120000</maxTime> 
</autoCommit>

maxTime is what you need, it's in miliseconds.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.