Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Windows 2008R2 I'm trying to set up my website so that it can be referenced as http://xyz.com/. It currently works when referenced as http://xyz.com/default.html.

I have added Default.html to the Default Document settings and I also checked the web.config to make sure it is there (see below).

I have Anonymous Authentication Enabled as a specific user. I also have Windows Authentication Enabled.

My predecessor got everything working fine in II6 but I can't figure out what I'm missing in II7.

share|improve this question
    
c tag removed. You don't want pointers (ha!) in answers, do you? –  pmg Jun 28 '11 at 21:55
add comment

migrated from stackoverflow.com Jun 29 '11 at 11:34

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 1 down vote accepted

It's possible that the default doc handler was removed. For example, if the httpHandler (Classic app pool) or handler (Integrated app pool) has a then it could pull important handlers out, which need to be added back again.

If you go to c:\windows\system32\inetsrv\config\applicationHost.config, search for defaultdoc and see the examples of what a default doc handler should look like. Then add that back to your web.config file. If it's not in apphost.config then you can install it using Server Manager and adding to the IIS role.

share|improve this answer
    
We tried this and also updated some settings on the ISAPI and CGI restrictions and now it is working. Thanks for your help –  GISMapper Jun 29 '11 at 15:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.