Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use Debian Stable (squeeze) on a virtual host where I can't touch the kernel, it's stuck (and will be for some time as support told me) at

Linux 2.6.18-028stab070.3 #1 SMP Wed Jul 21 18:33:27 MSD 2010 x86_64

So when I try to update, several packages fail with FATAL: kernel too old for example

Preparing to replace libgcc1 1:4.6.0-11 (using .../libgcc1_1%3a4.6.1-1_amd64.deb) ...
Unpacking replacement libgcc1 ...
Setting up libgcc1 (1:4.6.1-1) ...
FATAL: kernel too old
Segmentation fault
dpkg: error processing libgcc1 (--configure):
 subprocess installed post-installation script returned error exit status 139

and some version chaos ensued:

The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (> 2.13) but 2.11.2-13 is installed
 libc6 : Depends: libc-bin (= 2.11.2-13) but 2.13-5 is installed
 libc6-dev : Depends: libc6 (= 2.13-5) but 2.11.2-13 is installed
 libquadmath0 : Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-11 is installed
 libstdc++6 : Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-11 is installed
 locales : Depends: glibc-2.13-1

What should I do? I want to keep the system up-to-date, so I want to pin as few packets as possible, but I also don't want to have to compile anything manually.


Trying to pin the status quo and figured out where the error came from: ldconfig segfaults. -v doesn't print anything more so I can't tell what's the actual problem.

# ldconfig
FATAL: kernel too old
share|improve this question
    
You should "deal with it" by finding another provider. These idiots clearly don't want or deserve your business. –  Michael Hampton May 2 '13 at 0:46

2 Answers 2

up vote 1 down vote accepted

This looks like a frankenstein of a system that a vendor put together:

Debian hasn't shipped with a 2.6.18 kernel since Etch (4.0), but the kernel timestamp is after Etch's EOL. Additionally that kernel number system isn't Debian, so it is clearly a custom kernel.

libc6 version could be that from Squeeze (6.0), but gcc clearly is not. In fact, that gcc looks newer than what is in sid currently.

You've got similar problems with the other packages you list above.

What is the scope of this system? Do you really need to update the kernel? I ask because you may not be able to update the kernel without downgrading gcc and friends, which may break whatever proprietary software is on this vendor's system. Recompile is the other option but you said you didn't want to do this...

share|improve this answer
    
It's a Confixx Vitruzzo system, support tells me that's the latest kernel they provide and that I should deal with it. I "solved" it by pinning the libc6 version to 2.11.2-10 (and downgrading the packages dependent on it). I think it was an Etch system when I got it, upgraded to stable and pulled some packets that were too ancient from unstable and testing. The problem was that the postinst/postrm scripts all called ldconfig so I had to edit these… –  pascal Jul 1 '11 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.