Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've created a role with some limited access for my VWware infrastructure that is similar to the default Power User role. It appears that they do not have the ability to edit the comment field that is on Summary tab of the individual virtual machine. I can do it as an administrator.

What permission needs to be added to the role? I can't find anything like that in the list.

share|improve this question

2 Answers 2

It's 'Global'/'Manage Custom Attributes'.

share|improve this answer
    
It suddenly stopped working after we applied patches up to version ESXi 4.1.0, build 582267 –  SBWorks Apr 2 '12 at 6:28
    
Oh, so you just remove an answer approval there and then - wow, you totally understand how this site works... what a scummy thing to do. –  Chopper3 Apr 2 '12 at 8:27
    
Okay, then, @Chopper23, what was I supposed to do? It worked, and now it doesn't. Am I supposed to leave that as a an accepted answer? Open a new question? –  SBWorks Apr 3 '12 at 6:49
    
@SBWorks: If it worked and now it doesn't what did you change ? –  Iain Apr 3 '12 at 6:56
    
@Iain We applied patches up to version ESXi 4.1.0, build 582267 on the hosts. I don't have a record of the previous version, but it was very close to the "raw" RTM version of ESXi 4.1.0 on all the hosts managed by that particular vSphere system –  SBWorks Apr 3 '12 at 10:21

Found the answer in the vSphere Data Center Administration Guide, Page 254, Table A-22. Virtual Machine Configuration Privileges.

Privilege Name: Rename

Description: Rename a virtual machine or modifies the associated notes of a virtual machine.

I tested this out with my current vSphere environment and it appears to be correct. Adding the Global > Manage Custom Attributes option no long gives you the ability to Edit notes but Virtual Machine > Configuration > Rename does give you the ability to edit notes (which is not actually the best solution for me in this case but I may be stuck with it).

share|improve this answer
    
It looks like v5.0 changed the permissions again –  SBWorks Jun 11 '12 at 5:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.