Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm starting to configure collectd, but the main problem I got is that when I load the Network plugin it says next:

Could not find plugin network. Found a configuration for the `network' plugin, but the plugin isn't loaded or didn't register a configuration callback.

No idea why, should I install every single plugin? I thought it was installed by default, and... how should I install a plugin?

share|improve this question
    
Just in case, I set up the plugins path as: PluginDir "../lib/collectd" – arrrrgv Jun 30 '11 at 8:37
    
Have you tried using the absolute plugins path, i.e. "/usr/lib/collectd"? Is the "network.so" file there? – S19N Jan 6 '12 at 22:52
    
I am having the same problem. Each time I want to start collectd I have the error messages Could not find plugin dns. Coud not find plugin nut Did you manage to solve your problem ? The strange thing being that, in my case, everything was working fine until a power outage obliged me to reboot the machine. Thanks a lot – Hadrien Oct 24 '13 at 11:46

One important thing to note is that there is a HUGE difference between collectd 4 and collectd 5 .. Most distributions ship with collectd4, but the project site suggests it is outdated, and my encounters with version4 reveals much inconsistencies.

I will suggest that you do all you can to ensure you install collectd5 (instead of version 4.x) ..

As to plugins, you will find that the default install comes with all the plugins to satisfy most needs.

The config files imply that just copying the compiled '.so' files and adding the appropriate Loadplugin statements should be OK, but in my experience, plugins I tried would not work with this process. So, if you cannot find OS-packaged plugins, your best option would be to build from sources

share|improve this answer

protected by Community Oct 22 '15 at 1:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.