Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an RV220W but this issue may apply to other Cisco routers.

My website is deployed at public IP address 123.45.67.89/MyWebsite/Default.htm. My web server has an internal IP to which port forwarding directs HTTP requests.

Problem is, whenever I'm on the local network, typing in the above address gives me a 404 error. The reason being 123.45.67.89 is interpreted as the router itself! And not the web server that's supposed to receive the browser request.

Using any external network to access the website is fine. Using the internal IP of the web server when on this router's network also works (e.g., 192.168.0.123/MyWebsite/Default.htm).

But, despite Cisco support saying it's impossible, surely there's a way to stop the router from doing this?

share|improve this question

migrated from stackoverflow.com Jun 30 '11 at 12:44

This question came from our site for professional and enthusiast programmers.

    
Can you post your config? –  ElectricWeasel May 19 '11 at 18:15
    
I have the exact same problem with the RV220W model. It has only an online Gui which keeps me from trying what I think is the solution. You can configure static routing but have to define a lower metric (trusting of the route) than the router itself. –  The Shurrican Jun 29 '11 at 21:45

2 Answers 2

This problem is a classic when it comes to advanced routing / VPN.

The solution would be to define a static route (active, private) with your public IP as destination, give it a C-Class subnet, set it to interface "LAN" and give it the metric 1 (or 0).

The problem is that the GUI of this router only allows a metric from 2-15, so the router itself has higher priority and your rule will never work.

The scenario you want is called hairpinning.

Unfortunately this router seems not to offer CLI where you would be free to configure what you need.

If you have another IP at your disposal there would be the solution of 1:1 NAT but it looks that this router only supports 1:1 NAT xor NAT with one shared WAN address.

Routing instead of NAT is of course also an option but if you want to supply internet access to a lot of clients, which I think is the case because you bought a wireless router, you are in a n unlucky situation.

FYI am currently dealing with the exact same problem.

Here is a thread on cisco forums that corresponds to the problem. I didnt yet read all through it but there seems to be BETA firmware available that resolves the issue.

Quote:

There is a Beta Firmware which will resolve the issue. You must call the Small Business Support Center to get it (1-866-606-1866). Simply call, open a ticket, and tell the agent you're seeking RV120W Beta Firmware.

If you find a solution or get the firmware and it works for me please let me know by commenting on this answer. I will do the same :)

Also this question might be worth migrating to ServerFault.

Also I must add that I am not an expert at this subject, I am not 100% positive that I say is true, but I am very confident its correct. Another opinion would be nice. please feel free to comment on this answer if anything is wrong so i can adapt it.

edit:

I just hang in with the cisco support. The problem is known and documented. I am currently having an issue signed, that needs to be escalated, I have to sign some agreement that I will not pass on the beta firmware, and then they send it over.

share|improve this answer

A lot of SOHO-level NAT routers are not capable of looping traffic that originates from its LAN to the WAN and then back into the LAN. It's pretty common. Some manufacturers may offer firmware revisions which overcome this limitation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.