Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working on migrating a bunch of sites to a linode server running Ubuntu 10.04 & Apache2. I've pointed to the new domain name servers at linode, and created zone files. All this seems to have worked. When I load the URL, however, it's serving /var/www/index.hml. I'm looking for it to serve /srv/www/domain-name.com/public_html which is where the linode docs told me to put the site. (There is proper content in this directory.)

Any ideas what I'm doing wrong?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Assuming each "domain-name.com" is its own Apache virtual host, you should at least start by posting the output of httpd -S. This will enumerate all the virtual hosts Apache is serving up and indicate the IP:Port combination it is being served on.

If that command does include any namevhost output, several things could be wrong (starting with name-based virtual hosts being disabled in httpd.conf).

If the only output you see is a line stating "default server", it means Apache is only serving up some default content out of /var/www, it sounds like.

If there are multiple lines of output, one namevhost for each domain you are expecting to be served up, you should review your Apache configuration and ensure your Listen and NameVirtualHost statements reference the appropriate IP/Port for your new server. Likewise, in your Apache virtual configurations, ensure that the directives specify the IP address of your new server, not your old one.

share|improve this answer
    
Thanks so much for your help - I'm unsure how to ouput httpd -S from apache... –  starsinmypockets Jun 30 '11 at 15:08
    
Yes, the vhosts were simply not configured. I added the requisite files to /etc/apache2/sites-enabled, along with the associated directory in /srv/www/, restarted apache and this solved my problem. Thanks again! –  starsinmypockets Jun 30 '11 at 15:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.