Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I connect to a Cisco 2801 with the Cisco rollover (lt blue) cable, the output via putty shows a bunch of garbled text.

Here is a sample:

£·£²>±Ï¶³5ï46§4·´³´³µ»´f5£¶³4¯µ>3þ0¯´£µ³·4£ô3¾²°&1÷´«¶¯4ç´¿3þµ§44´»5£5ï6§µ¯4³³4«´¯4¶6³·³3¾4¯4¿¶Ï6Ï5Ï·¯[£5£4»´·´³4ß7£´³44«6³4³5«6£3ò3þ´«4£´62¿3Ï7ï6³¶£´>55O´»6£56«6×7£´£5»´ò²>1«4³´»7«´£41«5¿7¯µn6¯5î6ç0¿°´61°4®5²>0«¶5³´F4»5»4ï4·>µ«·³µ»·»¶

It seems as though it might be a cable/Putty serial settings issue, but I was able to us the same console cable/putty serial settings on a cisco switch and I could read the output.

I get the same output whether I'm using Minicom on Linux or Putty on Windows 7.

I also took off the cover, blew out the dust and re-seated the memory modules.

Any ideas what might be going on and how to fix? Thanks!

share|improve this question
1  
What serial line settings are you using? –  user48838 Jun 30 '11 at 18:21
    
I'm using the following: Bits per sec: 9600 Data bits: 8 Parity: none Stop bits: 1 Flow control: none –  user86268 Jun 30 '11 at 18:34

3 Answers 3

up vote 3 down vote accepted

This is all just guessing:

I haven't seen that exact garble before but sometimes if you see garble it's because your bits per second in your terminal emulator isn't set the same as the bits per second in your router configuration. 9600 is default but it can be changed in the router config. Perhaps someone changed the speed in the router config. You could try running through the whole range of possible bit per second speeds in your terminal emulator and trying to connect at each different speed and seeing if the garble goes away and becomes the clear readable text you're expecting at one of those speeds. That experiment should only take a few minutes.

I saw something like this once on a used Cisco switch, which had been configured by someone else, and this was the solution in that case.

share|improve this answer
    
Agreed, used to see this on our pix units when the baud rate wasn't right. Try each baud setting you can find and reset. IIRC there's no hardware factory reset (e.g., recessed switch) so that's not even an option here. –  nedm Jun 30 '11 at 19:44
    
caleban, you nailed it! The serial setting was changed from 9600 to 19200! I'm not just good, I'm golden! Thank you! –  Nick362 Jun 30 '11 at 20:18
    
Awesome. Glad I could help. –  caleban Jun 30 '11 at 22:06

I think the 2801 has both Console and Aux ports. Which are you using? the Aux port expects a modem and requires hardware flow control.

Make sure you are using the Console port.

(Edit: The Console port should be colored blue to match the cable.)

share|improve this answer

Ok, in that case, can you remote into the unit (ssh/telnet)? It looks like someone might have changed the serial line settings on the unit's console port. You might also try auxiliary port as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.