Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have apache2 running on a Mac OS X (10.6) machine, and it is currently serving PHP pages fine, using php5_module but I would like to configure fastcgi_module to handle the php pages.

I have tried using the configuration found on www.fastcgi.com but I get the following error:

[warn] FastCGI: (dynamic) server "/Path/to/script.php" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds
[warn] FastCGI: server "/usr/bin/php" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds

I'm thinking this is because PHP has not been compiled with FastCGI, but seeing as it came with Mac OS X i'm not sure how to recompile it. Is this the problem? And if so, how do I recompile PHP with FastCGI?

share|improve this question

1 Answer 1

you might try /usr/bin/php5-cgi instead, which is not only for cgi but also for fastcgi. This applies to standard debian, but it probably works on OS X too.

share|improve this answer
    
That doesn't exist on the default Mac OS X PHP installation unfortunately. –  DanielGibbs Jun 30 '11 at 23:27
    
It probably is in a binary php distribution, like here –  John Smith Jun 30 '11 at 23:33
    
Yea it is. How would I go about replacing it with a version of PHP with FastCGI enabled? –  DanielGibbs Jul 1 '11 at 0:02
    
i don't know how to to this on Mac, you could try installing php from macports or entropy, and use the installed version. Also i think it's better to use the fcgi module instead of the fastcgi, it works better with php, afaik. –  John Smith Jul 1 '11 at 16:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.