Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am in charge of a small domain of 20 or so computers. I recently found how to get the windows XP machines to get their time from our domain controller using this batch file:

call w32tm /config /syncfromflags:domhier /update

call net stop w32time

call net start w32time

and it worked great.

I tried the same thing on Vista with no success. Any help?

share|improve this question
    
You could just enforce the setting using group policies. :-) It's under the "Windows Time" category. –  Chris Jester-Young May 1 '09 at 23:51
add comment

4 Answers

Quote from http://support.microsoft.com/kb/307897

If the computers belong to an Active Directory domain, the Windows Time service configures itself automatically by using the Windows Time service that is available on domain controllers. The Windows Time service configures a domain controller in its domain as a reliable time source and synchronizes itself periodically with this source. You can modify or overwrite these settings, depending on your specific needs.

share|improve this answer
add comment

Run the following command to determine if a time server is set:

net time /querysntp

If it is, then you'll need to clear it. You can do that by:

net time /setsntp:

If you want to do it remotely, you can do:

net time \\Computer /querysntp

and

net time \\Computer /setsntp:

By leaving it blank after the /setsntp: command, you clear the list. Your Vista (and Windows XP computers) that are on an Active Directory should sync team with the DC they are talking to for authentication.

share|improve this answer
add comment

Vista should be setup to get time from your domain controller by default. You shouldn't set a client to sync with a sntp time server, only the DC with the PDC role should do this (and will be configured by default to sync with the sntp server time.windows.com).

If the vista PCs are not getting the correct time it could be that they are too far out of sync, in which case the time service decides it's safer not to interfere (if it's more than a few minutes out). This can arise because you don't have PCs in the correct time zone.

share|improve this answer
add comment

learn a few things I've always done this to fix desktops:

net time /DOMAIN /SET /Y

this will force the workstation to set its time to the on the domain controller. Usually after this I havent had to go back and keep it in sync after that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.