Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Similar to my previous question Cannot delete unresponsive machine on VMWare Infrastructure Web Access on Windows 2003 host and now YET another virtual machine has stopped at 95% (while starting up) for no just reason. Unfortunately in this case there is no recent backup for this particular one [Yes I know :( ]

I think I foolishly botched things further cos I tried to create a new virtual machine using the same virtual hard drive (in a bid to rescue the data from the unresponsive machine) and the browser hung (IE 8). When I restarted the browser, I stupidly removed the virtual machine new copy (I guess that deleted the .vmdk file? I didn't know it would). After my folly I looked in the vmware virtual machines folder and saw only the .000001.vmdk file. Can I recover the original vmdk from this file?

I have tried using WinMount to mount the Winbox.000001.vmdk. It tells me "Illegal VMDK descriptor". I have also tried the VMWare DiskMount Utility (vmware-mount) but I get the following when I reply the prompt for a Yes:

C:\Program Files\VMware\VMware DiskMount Utility>vmware-mount.exe W: "X:\Winbo x.000001.vmdk"

This disk is being used by a virtual machine that has an active snapshot.
If you proceed, any changes you make are applied to the current version of
the disk, and will be discarded if you revert to the snapshot. Do you
wish to proceed (Y/N)? y
Unable to mount the virtual disk.  The disk may be in use by a virtual
machine or mounted under another drive letter.  If not, verify that the
disk is a virtual disk file, and that the disk file has not been corrupted.

The disk is "in use" because it has hung at 95%? I critically need to get some files out of this machine one way or the other. Please help. Suggestions?

ETA: I am currently trying the evaluation version of MediaHeal VMDK Repair tool but besides their own testimony on their site, I can't see any references to this software anywhere. Do you know any alternatives to repair, fix or recover data from a corrupted VMDK file?

share|improve this question
    
MediaHeal VMDK Repair tool has finished. It found only the Windows partition though the evaluation does not allow saving of data. But the other partition is missing, and that's where the data is! :( –  Cogicero Jul 1 '11 at 11:33
    
Now using UFS File Explorer. C partition found, but D partition reads "Unknown file system". Still checking... –  Cogicero Jul 1 '11 at 12:16

2 Answers 2

up vote 0 down vote accepted

So I solved my own problem.

  1. I used UFS File Explorer to load the vmdk file and discover the drives. The D partition read "Unknown file system".

  2. Within UFS File Explorer I saved the D drive as an IMG file.

  3. I loaded the IMG file using Runtime's GetDataBack for NTFS and after scanning sectors for data, I got my data back. Some of it was corrupt, but over 90% was in good shape. I simply conflated the data with the week-old backup.

:)

share|improve this answer
    
I used WinMerge winmerge.org to compare the recovered folder with the old backup folder. –  Cogicero Jul 1 '11 at 13:25
    
Remember to mark this question as resolved by clicking the check mark. This keeps coming back as an unanswered question because you haven't done so. –  Michael Hampton Jun 8 '13 at 6:00
    
Thanks Michael! –  Cogicero Jun 25 '13 at 23:48

It is important to take a fresh backup every time so that whenever these types of problems have come then, you can simple restore your important data via this backup file. If you don't have a backup copy then, just chill! Here is another professional solution that permits to recover lost/missing/formatted partition data. Commercial solution named - VMware recovery application perform deep scanning and will salvage even a large sized files data with 100% assurance of accuracy.

Read more: http://gallery.technet.microsoft.com/Recover-VMDK-Data-from-bd1ecd39/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.