Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using VirtualBox to run a Ubuntu 11.04 Server as a guest OS. However, using NAT the VM get's a private IP.

I want my guest oses to get their own IP on the network the host is on. I.E., my host's IP is 192.168.10.109, I want the guest to be 192.168.10.110 instead of 10.?.?.?.

How may I do this?

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

You need to assign what is called a Bridged Adapter. In the main VirtualBox window, select the VM you want to work with and click the Settings icon. In the settings window, go to Network, and you will see the Settings page for "Adapter 1" Change "Attached to:" to "Bridged" and you should be good to go.

Here's a graphic of what you need to do (change #4 to Bridged): enter image description here

share|improve this answer
    
+1 for screenshots =) –  Handyman5 Jul 1 '11 at 21:09
add comment

It's called "bridged" network. Change the network settings for the VM.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.