Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an IBM server xSeries 205 with a ServeRaid 4Lx on it that after a power faliure refused to boot. it presented a error message during ServerRaid BIOS boot phase stating:

ServeRAID? ,Slot1, Status: Controller register test failed, test number 01

after this message a few seconds later the server hangs completly

on the IBM support site i found this:

Controller Reg. test failed. Test Number:
Explanation: The adapter or embedded controller failed the register test, where is the register number and is the test number. Action: Reseat the adapter. If the problem persists, replace the PC ServeRAID Adapter.

I flashed the controller again with the latest firmware and the problem persisted, then i ordered a new Controller and replaced it and the problem is still there.

i found a work around. After this error messages appear i can restart the server (CTRL+Alt+del) and the next time it boots everything works fine.

Can any one help me out finding the source of the problem or how i can solve it?

Things that i have tried to solve the problem:

 - Updated BIOS of Server and Controller
 - Switched PCI Slots
 - Replaced ServerRaid Controller with brand new
 - Unplugued all scsi wires and tested the boot sequence

thanks very much for your time

share|improve this question
Is the controller going into the same slot each time? – Chris Jul 6 '11 at 0:51
I have tested differentes PCI slots, unpluguing the HD and the problem is always the same... last nigth this server froze up and now im not even able to reinstall the operating system. it starts the Installation software and freezes after the windows logo. also the currently installed OS frozes at random intervals. and when the server freezes all 5 LEDS on the controller turn on and they stay like that until the server is power off – Hugo Garcia Jul 6 '11 at 21:59
I just noticed that this all started with a power outage (and thus a possible surge as well.) So, I have a second pair of suggestions. One. reset the BIOS on board according to the manual: and then 2. try replacing the power supply. – Mark Jul 7 '11 at 13:24
It could also be bad RAM. You might also try re-seating the RAM, or swapping out/removing to eliminate a bad DIMM (assuming you have more than one). If it still fails after that and the steps Mark suggested, I'd suggest it's the system board. – Chris Jul 7 '11 at 14:48
More news... i know have complettly removed the controller and run a linux distro to make some tests and the server hangs a few minutes later the interface is up. this is preaty odd. i'm removing the ram modules and do some more testing, btw when i run the x86memtest sofware to check the RAM the server stays there for hours and no problem is detected – Hugo Garcia Jul 7 '11 at 19:25

If the card is plugged into one of the two slots on the PCI extender, consider moving it to the slots on the main board. It may not be getting enough power early enough in the boot cycle to perform its POST. Changing the slot it is in could help. If the system is lightly loaded with cards, try and have the slot next to it unused, as well.

share|improve this answer
Hi.. thanks for the sugestion, i allready switched PCI slots and the problem does not disappear – Hugo Garcia Jul 6 '11 at 21:57

Check the syslog in the linux distro else


  • you tested your ram
  • you tested the card in another server
  • your CPU still works without errors (syslog in linux)

You might want to conclude you could have a problem on your motherboard.

share|improve this answer
up vote 1 down vote accepted

I finally solved the puzzle, the problem was because a power surge that fried the Mainboard... i didn't give any attention first, but on closer inspection the condensers on the motherboard where all leaking and some of them exploded.. i'm surprised this thing even booted.

any way, thanks every one for the help.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.