Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Centos 5.6 Linux Server configured as Router with NAT for my LAN. There are currently 2 NIC's on my server. One is connected to WAN , a PPOE connection (eth0) and eth1 is connected to a switch which supports my LAN. I have enabled NAT and configured iptables on my server and I am able to access internet from LAN and everything is working fine.

I have a Belkin F5D8233-4v3 Wireless router and I need to configure wireless on my network so that I can access internet from my Laptop. The issue is that I have only 2 NIC's on my server, one Gigabit NIC integrated with my motherboard and another NIC which I am currently using for WAN access and LAN. I need to setup the Belkin as an wireless Access Point.

Can I connect my Belkin to my switch and set it up as a Wireless Access Point?? I have read about setup using 3 Nic's.

Any ideas on how to configure my Belkin as Wireless Access Point with my existing setup???? Is Belkin F5D8233-4v3 supported on Linux...Googling did not provide any information???

share|improve this question
In future, don't cross-post. Just flag and ask for migration. – random Jul 2 '11 at 4:09

According to this page you can set the device to be an access point. If you assign it a static IP inside the LAN side of your network and attach it to your switch you will be able to connect wirelessly and route to the Internet via your existing gateway.

The AP itself doesn't need to "support Linux", just needs to bridge wireless connections to wired and your existing network infrastructure (DHCP, DNS, NAT) will take care of the rest.

share|improve this answer
Thank you Kyle. Will give it a try... – shels Jul 2 '11 at 2:31
I am unable to access modem or router home page to configure IP from my centos box – shels Jul 2 '11 at 3:19
Done...and worked perfectly...Thank you... – shels Jul 2 '11 at 11:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.