Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here's my situation, in short.

I've got a very popular web application, with about 35M page views per month. The relevant stack to this question is that I currently run a Win2K8R2 central file server (in a DFS-R config for failover and additional performance) with quite a few 15K 600GB disks in a RAID 10 config. I run about 6 million files. I have a swath of Win2K8R2 web servers connecting to this file server. The "adding storage as needed" story isn't as glamorous as in the Linux world, so I set out to change that.

Enter GlusterFS. I've researched for over two years to get to this point, and love everything about GlusterFS. I've tested it, and love the story of, "if you're out of space, add a couple bricks, one for extra storage and the other for mirroring." Boom, you're done.

My question, however, isn't related to GlusterFS at all (I think).

My problem is that I have my GlusterFS mount exported to a Samba share. I can connect my web servers to the share fine through Explorer and can successfully add and delete files. My problem comes when I point a website to that UNC share.

I put in my credentials to the share, and everything checks out great. In an ultra-simple Hello World app with a single DLL in the /bin folder, I can get it to run great. However, some, and only some, assemblies will generate the following error, for example:

Could not load file or assembly 'AjaxControlToolkit' or one of its dependencies. Strong name signature could not be verified. The assembly may have been tampered with, or it was delay signed but not fully signed with the correct private key. (Exception from HRESULT: 0x80131045)

Some assemblies load fine, though. Some don't. I open up the properties for the offending assemblies and I don't see the "unblock" button, and all security checks out fine, with the user I'm connecting to the UNC share having full permission over everything. I've also given full trust to the UNC share on the web server, like I always have done in the past using caspol. I've never seen this error crop up on a normal Windows share, and I've been running in this same kind of IIS/UNC setup for years.

What am I doing wrong? Samba mis-configuration? Here's my smb.conf:

[App]
comment = GlusterFS app export via SAMBA
valid users = administrator
printable = no
writable = yes
public = no
path = /mnt/glusterfs
posix locking = yes

This is driving me bonkers. I feel like I'm so, so close, and these random DLL "could not load file or assembly" errors feels like I'm being clubbed in the knees with baseball bats. That's how much I've tried to get it to work so far.

share|improve this question
    
Assuming you got this fixed? If you have any input, I am having the same issue. –  user113806 Mar 12 '12 at 23:23
    
@Nate Ken hasn't checked in for about a month, I wouldn't hold out on him responding soon. –  Chris S Mar 13 '12 at 0:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.