Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is the scenario:

I have several(17) Windows 7 machines joined to a Samba domain. We have a situation where the Win 7 machines need to be renamed.

To accomplish this this is the procedure I have been following: 1) Take machine out of the domain 2) Rename the machine 3) Rejoin the machine to the domain

This process has worked for the first 4 machines perfectly but now for the fifth machine it fails with the following error: the following error occurred attempting to join the domain the handle is invalid

Anyt suggestions would be most appreciated.

*SOLVED*
Well one repair install and many hours of trouble shooting later it was something I should have checked much earlier

A hinky network card.

share|improve this question
    
If you haven't already (as you don't mention it) then you need to isolate whether or not this is a workstation issue or a server issue. So machines 1 to 4 work and 5 does not, ok. So what do the rest of the computers do? Is there anything different in how the OS was deployed onto machine number 5 compared to machines 1 to 4? –  RobM Jul 3 '11 at 14:48
    
They were all installed exactly the same about 10 months ago and have the same configuration. This machine had previously been joined to the domain. But since removong and changing it's name it will not rejoin. –  Nunya Jul 3 '11 at 16:03
    
@Nunya - if you have solved your own question, please post your solution as an "answer" and give it the checkmark so that others can find it easier in the future. –  Mark Henderson Jul 4 '11 at 11:36
    
@Mark_H - Thanks I will do that now –  Nunya Jul 4 '11 at 12:23

1 Answer 1

Did you check your dns settings to make sure they are correct. Try running ipconfig /flushdns.

Windows 7 or 2008 Server Instructions

  • Click Start
  • In the Search Programs and files field type View Network Connections and hit Enter
  • When your Network Connections appear, right click on your active connection > click Properties
  • Double-click Internet Protocol Version (TCP/IPv4)
  • Update the Preferred DNS Server field with the IP address of your primary domain controller > Click OK > OK again
  • Now try to join your domain again.
share|improve this answer
    
Not using DNS for the domain and have changed the corresponding registry key to allow Win7 to joina Samba Domain. –  Nunya Jul 3 '11 at 13:59
    
Not using DNS for the domain and have changed the corresponding registry key to allow Win7 to joina Samba Domain. [HKLM\System\CurrentControlSet\services\LanmanWorkstation\Parameters] And create the following strings: "DomainCompatibilityMode"=dword:00000001 "DNSNameResolutionRequired"=dword:000000 –  Nunya Jul 3 '11 at 14:06
    
If you're not going to use DNS, it still has to be able to locate it's peers to join said domain. There are tools, maybe nbtstat for checking this. –  SpacemanSpiff Jul 3 '11 at 15:07
    
It does not use DNS hence the key change above it uses WINS netbios over tcp/ip. It is a Samba Domain not AD. –  Nunya Jul 3 '11 at 16:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.