Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Windows Home Server connected to my home network on which I have just installed SQL Server 2008 R2, I am aiming to connect to the SQL Server installation from my laptop using SQL Management Studio using my Windows Credentials (I selected mixed mode authentication during installation).

I have a few questions about both the installation and connection:

  1. What is the default instance and how is it used within SQL Server?
  2. In the connection screen on my laptop I can select my server itself as a database engine, is this correct?
  3. When I try to connect via step three I receive a timeout error, (Error number -2), how would I go about fixing this?

I hope I have provided enough information, feel free to let me know if you need anything else.

Thanks for your time.

Solution (Expanded from Ganesh R.):

After following some of the guidance by Ganesh it led me to this article:

SQL Server Connection Error

The problem was my Home Server was blocking any attempt to connect to the database due to Windows firewall, one exception rule later and it works great!

share|improve this question

closed as off-topic by HopelessN00b Feb 6 at 10:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – HopelessN00b
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

up vote 3 down vote accepted

From what you mentioned, it seems there are two machines:

A. Your home server with SQL 2008 R2.

B. Your laptop with SQL Management Studio.

Points to remember:

  1. What edition of SQL 2008 R2 did you install on the home server? Is it full version (STD/ENTERPRISE) or express? If it is full version, then by default, the default instance is installed. Else named instance is installed. (To check the edition, open services.msc from run prompt and search for a service named "SQLSERVER". If it has MSSQLSERVER besides it, then its default instance. Else whatever name is mentioned is the Instance name.)

  2. If it is the default instance, then TcP-IP connections is enabled by default. Else if it an named instance then you will need to enable TCP-IP connections.

  3. Now from your laptop connect as: For default instance use just the machine name. For named instance(SQLEXPRESS) use MACHINENAME\INSTANCENAME to connect.

  4. You do not need mixed mode authentication to connect to SQL Server using Windows Credentials.

share|improve this answer
I have the Standard edition of SQL Server 2008 R2, I'm trying to connect to SQL server just by the machine name (Server name) and it says it cannot connect. – Jamie Keeling Jul 3 '11 at 19:19
Did you turn off the firewall on the Server machine? – Ganesh R. Jul 4 '11 at 4:26
I did something similar, added a new rule to the firewall which solved the problemm :) – Jamie Keeling Jul 4 '11 at 11:59

In the connect dialog, you can use just the server name as the database engine. If it was a SQLExpress install, it would be something machinename\sqlexpress (or .\sqlexpress for a local install).

This should 'just work', at least it has for all my previous installations.

If you connection is failing, try enabling the SQL Server browser on the remote machine and enabling named pipes.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.