Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I booted up a RHEL server on EC2, started httpd, added an index.html page for testing purposes, but when I try to access the website through the public DNS address, the page is not found.

I can curl the address successfully from the server itself, but get nothing when I try to curl it from my local machine.

It has been 12 hours now since I have started the instance, more than enough time for things to get set up on Amazon's end.

EDIT: My security group does allow access on port 80

Any thoughts?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You may need to open the port on the security group. Amazon maintains separate firewalling than simply the iptables (or equivalent) that you will run on RHEL. From the AWS console, open port 80, and apply - the change should take place almost instantly.

share|improve this answer
    
Already covered, good call though, forgot to mention that in my question. –  Andrew Guenther Jul 3 '11 at 19:43
    
A few suggestions in that case, try using an external service to retrieve your webpage (e.g. a speedtest) - that will discount issues with your local machine (firewall, dns cache, etc); Do you get a 404 page not found, or another error (e.g. a DNS error? or Server not found, etc) –  cyberx86 Jul 3 '11 at 19:48
    
I am getting a "could not connect to host" error. So it is obviously there, but for some reason not accessible –  Andrew Guenther Jul 3 '11 at 19:51
    
Well, other suggestions in that case would be check your ipTables (perhaps only allowing local access?); ensure you are not using the private DNS; try to use the IP version of the public DNS instead of the text version Amazon gives. –  cyberx86 Jul 3 '11 at 19:56
    
Just fixed it, Red Hat's firewall was blocking the connection, the iptables were fine when I checked though, which was strange. But everything works now. Thanks a ton for your help! –  Andrew Guenther Jul 3 '11 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.