Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying something similar to . This is my xml file :

<domain type='kvm' xmlns:qemu=''>
    <type arch='x86_64' machine='rhel5.4.0'>hvm</type>
    <boot dev='hd'/>
  <clock offset='utc'>
    <timer name='pit' tickpolicy='delay'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/root/incremental.img'/>
      <target dev='hda' bus='ide'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    <controller type='ide' index='0'/>
    <interface type='bridge'>
      <mac address='00:16:3e:98:78:04'/>
      <source bridge='br0'/>
    <serial type='pty'>
      <target port='0'/>
    <console type='pty'>
      <target port='0'/>
    <input type='mouse' bus='ps2'/>
        <graphics type='vnc' port='-1' autoport='yes' keymap='en-us'/>
          <model type='cirrus' vram='9216' heads='1'/>

        <qemu:arg value='-s'/>

I start the VM from this xml file. Now When I do "ps aux | grep rubis" , I get :

root 13496 59.1 3.5 1266168 292112 ? Sl 16:50 0:23 /usr/libexec/qemu-kvm -S -M rhel5.4.0 -m 1024 -smp 2,sockets=2,cores=1,threads=1 -name rubis_ws -uuid 1a474ca9-604f-aceb-2fed-792fe1e9f900 -monitor unix:/var/lib/libvirt/qemu/rubis_ws.monitor,server,nowait -no-kvm-pit-reinjection -boot c -drive file=/root/incremental.img,if=ide,bus=0,unit=0,boot=on,format=qcow2,cache=none -net nic,macaddr=00:16:3e:98:78:04,vlan=0 -net tap,fd=18,vlan=0 -serial pty -parallel none -usb -vnc -k en-us -vga cirrus -balloon virtio

root 13531 0.0 0.0 61192 760 pts/5 S+ 16:51 0:00 grep rubis

I cannot find the -s in that command . Can you please let me know whether I am making any mistake. I have been stuck with this for a long time without knowing how to solve it. My ultimate aim is to make this command argument work and use it for -incoming tag using qemu command line argument with libvirt.

Thanks for your help.

  • Regards, Sethu
share|improve this question
up vote 0 down vote accepted

on what distro are you doing this? Might be that your libvirt build is too old to support this option

share|improve this answer
I see. Im using libvirt 0.8.2 .Its not supported in this distro ? – sethu Jul 6 '11 at 18:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.