Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am initiating file transfer using tcp on openfire server. But I am not able to open the port number 7777, from which I need to send files. I changed the security setting in the admin console panel of the aws. But still when I tried to send the files I am getting the error.

I tried to change the custom TCP rules, by opening only the 7777 port. But still I am not able to resolve it. Kindly help.

linux ubuntu

share|improve this question
    
Is your FTP server actually listening on 7777? –  Chopper3 Jul 4 '11 at 8:29
    
@Chopper: How do I test it??? –  Jeevan Dongre Jul 4 '11 at 9:09
2  
Well did you specifically change your ftp server config to listen on 7777? they dont just listen to every port for the hell of it - in fact port 7777 is usually used by a piece of malware/virus, certainly isn't a recommended port of ftp traffic. –  Chopper3 Jul 4 '11 at 9:14
1  
A quick test would be netstat -an|grep 7777, which doesn't need privilege to run. Let us know the output. –  MadHatter Jul 4 '11 at 9:20

1 Answer 1

up vote 1 down vote accepted

It is possible that your AMI has a firewall enabled that is blocking port 7777. Ubuntu usually uses ufw to control it's firewall.

run

sudo ufw status 

If it reports

Status: inactive

then your problem lies elsewhere.

If it reports

Status: active

followed by a list of rules then you probably need to add a rule to allow access on port 7777

sudo ufw allow 7777
share|improve this answer
    
@lain: it was inactive first then I enabled it i got the msg saying"Rules updated" but I tried sudo ufw allow 777 but still the status is inactive, what will be the problem I have updated the security group to accept all TCP and UDP rules –  Jeevan Dongre Jul 4 '11 at 10:41
    
@JeevanDongre: If the firewall was inactive (like I said) your problem lies elsewhere. –  Iain Jul 4 '11 at 13:53
    
@lian: let me brief u about the application which I am developing I have installed open fire xmpp chat server in the server and I am trying to initiate the p2p, that means sending files from one mobile to another mobile via port 7777, which is a default port in openfire server, but I am not able to open that particular port. Thanks a lot for guiding me :) –  Jeevan Dongre Jul 5 '11 at 4:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.