Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Help, I have a mission critical VPS runing Ubuntu 10.04 , which I am using for django. the web-app has been running fine for a month and then suddenly I can't write to the sqlite database anymore, getting an "disk i/o" error (no problems reading from it though). which from what I can tell is usually permission problem. Nothing worked so I tried reseting the permissions to 777 and owner to www-data allong on the directory it's in and all the files, still no luck. I then SU'd to the www-data user and ran echo "hi" > hi.txt followed by cat hi.txt, and it was blank. I ran ls to see if it had been created even, and it was there, it was just blank. I switched back to root and ran cat hi.txt, and it was still blank, so I ran echo "hi" > hi.txt again followed by cat hi.txt and it now said correctly "hi" back. I switched back to www-data to see if I could read it, and I could. www-data is the owner of hi.txt and permissions where 644 . What can I do? It seems like www-data suddenly can't write inside a file (it can however create them), but can only read no matter what the permissions or who owns it. Help!

share|improve this question
up vote 3 down vote accepted

Smells unpleasant. My first suspicion would be a filesystem problem with symptoms that screwy. Check dmesg for filesystem errors, perhaps take a maintenance to do a fsck to be sure.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.