Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The version of Disk Utility that comes with Mac OS X 10.5 will let you resize existing partitions on a partitioned drive -- some of the time. What determines if it will let you adjust partition sizes or not?

share|improve this question
up vote 2 down vote accepted

Fragmentation would probably be the biggest problem. For a newly formatted partition, data will be added (more or less) from start to finish, however after a time fragmentation will leave blocks of data all over the disk. DiskUtil cannot resize a volume to a size less than the last block in use on the partition.

To defragment your partition, thereby moving all the data to the front of the disk, you can use a program like iDefrag. Alternatively you can simulate the process by copying all your data off to another disk, reformating the volume, then copying it back. You can use a program like SuperDuper or Carbon Copy Cloner to help with this process.

There may also be restrictions on resizing the startup volume. To avoid those, boot from the install DVD.

share|improve this answer
HFS+ can be defragged, in fact there's lots of options including iDefrag ( – Chopper3 Jun 19 '09 at 14:52
@Chopper3, I never knew about iDefrag. Thanks for the suggestion, i've updated my answer – Dave Cheney Jun 19 '09 at 23:51
I could adjust the sizes on the partitions on my startup drive, but not on an external drive (which had two HFS+ partitions). This is what led me to believe some subtlety is involved. – Clinton Blackmore Jun 20 '09 at 0:02
What partition format are they, GPT, MBR or Apple Partition Map ? – Dave Cheney Jun 20 '09 at 0:10
I was just trying this again on another computer. Trying to resize it failed. I ran some tools (which weren't entirely clear), but it did seem to be fragmented. I optimised it with Disk Warrior. Then I tried to resize it again ... and it almost worked. At the end, Disk Utility said it had lost its connection with an internal tool that it works with and needed to quit -- leaving me with an unmounted volume in who knows what sort of health. Glad I backed up first! – Clinton Blackmore Nov 6 '09 at 18:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.