Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm not the network admin, but my network admin is having trouble solving this as well.

My issue is exactly as the title says...

Windows Security (In windows 7) keeps asking for my credentials, and won't "Remember my credentials"

Even if I check mark the box that says "Remember my credentials", I'll eventually be prompted to enter my credentials again.

I am an administrator for this computer.

Please let me know if there's any other details I can provide! enter image description here

share|improve this question
So I have a couple questions for you: Is your computer on the domain you are connecting to? How high is your UAC? If you are on the domain it may be a group policy that you must enter your password to access the domain or you are trying to access a file that you don't have rights to. You may want to try the solution posted on SuperUser… Hope that helps. –  wyo9089 Aug 1 '11 at 16:16

4 Answers 4

up vote 1 down vote accepted

I was able to find the solution at this forum

Essentially go to the Windows Vault (Store credentials for automatic logon), and edit the credentials there.

share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Mark Henderson Sep 23 at 15:02

None of these aforementioned methods solved my Win7 remembering credentials problem. However, after many trials, I discovered that the problem was caused by the remote device's computer name coinciding with one of its local user names! I changed the computer name to something different than all of the local user names, then entered my remote credentials and enabled "remember my credentials" once again. After that Win7 never asks me again to logon for access to the remote computer.

share|improve this answer

This is a issue with your Windows Credential Manager. Moste likely because your credential manager have wrong entry with and old password or if it was selected to be disable.

Write Credential Manager at the start menu and open it. Check if it is allowing save password and if it is delete all the entries saved and try again. If it's not allowing to save password it's possible that it is setting from a domain groupo policy and your network admin should check it.


share|improve this answer

For windows7, Go to control panel -> credential manager, there you will get Windows credentials, Generic credentials, select each option and click on remove from vault to delete old saved passwords and check now, it will not ask again for username nad password!

share|improve this answer
Isn't this the same instruction as the accepted answer? –  jornane Aug 13 at 11:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.