Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to replace my linux gateway box to Mikrotik. But I never found how to write this linux's iproute2 command in mikrotik's way:

ip route add default via 10.1.1.1 table browser
ip route add 10.1.2.0/24 via 10.1.1.2 table browser
ip rule add prio 100 from 10.1.6.2 lookup browser

anyone could lead me how to create a new routing table instead using the main's route?

share|improve this question

1 Answer 1

The following should do the trick:

/ip route
add gateway=10.1.1.1 routing-mark=browser
/ip route
add gateway=10.1.1.2 dst-address=10.1.2.0/24 routing-mark=browser
/ip route rule
add src-address=10.1.6.2 action=lookup table=browser

Note that in RouterOS, the priority is set by the order of the routing rules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.