Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently successfully installed TinyDNS on my CentOS server. I have followed these examples and guides here, here, and here.

The issue is that I am unable to nslookup/ping any domains I setup in the data file for TinyDNS. I have 2 name servers registered through my domain registrar to ns1.minecraft-cheats.com and ns2.minecraft-cheats.com with 2 IP addresses pointing to the same server (the server with the TinyDNS on it). Here is the layout of my /var/dnscache/tinydns/root/data file:

Zminecraft-cheats.com:ns1.minecraft-cheats.com:2011070501:4800:1800:604800
&minecraft-cheats.com:184.168.110.107:ns1.minecraft-cheats.com:3600
&minecraft-cheats.com:184.168.123.220:ns2.minecraft-cheats.com:3600
=minecraft-cheats.com:178.63.65.196
=www.minecraft-cheats.com:178.63.65.196

When I use dig on the domain here is the results:

[root@ip-184-168-110-107 root]# dig minecraft-cheats.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> minecraft-cheats.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62345
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;minecraft-cheats.com.          IN      A

;; ANSWER SECTION:
minecraft-cheats.com.   86400   IN      A       178.63.65.196

;; AUTHORITY SECTION:
minecraft-cheats.com.   3600    IN      NS      ns1.minecraft-cheats.com.
minecraft-cheats.com.   3600    IN      NS      ns2.minecraft-cheats.com.

;; ADDITIONAL SECTION:
ns1.minecraft-cheats.com. 3600  IN      A       184.168.110.107
ns2.minecraft-cheats.com. 3600  IN      A       184.168.123.220

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Jul  5 10:52:26 2011
;; MSG SIZE  rcvd: 122

I am aware it isn't very safe to post the real IP and domain name but I really don't care right now.

When I edit the data file I am running 'make' and then restarting the TinyDNS service.

Can someone tell me what I am doing wrong? Yes, I have waited hours for propagation to occur so I do not think that is the issue at the moment.

Found a good website that diagnoses DNS issues: http://www.intodns.com/minecraft-cheats.com

share|improve this question

3 Answers 3

up vote 2 down vote accepted

The instructions by the pseudonymous cyberx86 that you have followed are wrong. As written, you'll end up with two different severs, one dnscache and tinydns, providing two different services but both listening on the same IP address and port. This explains the currently observable behaviour, that all of your servers appear to be dnscache not tinydns. Xe has made a further error of having /etc/resolv.conf pointing to the wrong type of DNS server, as well.

Follow the instructions from the author of the program, instead.

share|improve this answer
    
Extremely helpful, I have it working now but only on 1 IP address (I have 3 I want to use). Not sure how to go about doing that –  qroberts Jul 5 '11 at 23:45
    
Three service instances, one per IP address, all sharing a single root directory with symbolic links. Simple. –  JdeBP Jul 6 '11 at 6:59

You probably need to update the nameservers for the domain. In your data file you list ns1/ns2.minecraft-cheats.com but the whois info shows dns1/dns2.namecheaphosting.com.

share|improve this answer
    
Okay I just changed that, I'll give it a little bit. –  qroberts Jul 5 '11 at 18:12

You should be able to run dig @8.8.8.8 minecraft-cheats.com NS and get a nameserver spit back at you. I can't; therefore, your problem is with your registrar. Talk to them. Your TinyDNS setup seems fine.

share|improve this answer
    
pastie.org/private/hbqrzhq054zfbeax6nvlua Is what I get –  qroberts Jul 5 '11 at 18:08
    
Looks to me like the query failed. You should update your registrar's NS records. You'll need to both create the glue records and set your domain to use them; I'm guessing you only did the former. –  Michael Lowman Jul 5 '11 at 18:13
    
I think I know what you are talking about, I just changed those settings (d'oh) and I will see what happens in a little bit. –  qroberts Jul 5 '11 at 18:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.