Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Am struggling to get my head around this issue and feel I am missing something obvious or may have approached this in the wrong way and would be grateful of all help.

I have an ESXi server connected to my home router. Flatmates also connect to this router for normal internet access. What I wanted to setup for a home lab was a small MCSA domain on my ESXi server. This has been going fine by just using the DHCP of the router and assigning static IPs to the virtual servers. What I want to achieve is having a more separate virtual labe that does not really touch the addresses on my router. To do this I set up two NICs on SERVER01 (yep, very much following the books on the MCSA for names and such). One (called Internet) has a static IP 192.168.0.201 and this is the connection to the router and the internet. The second NIC (called LAN) has a staic IP of 10.168.50.1. I setup RRAS to be in NAT mode and all seems to go well.

The downside is that if I try and configure a new host or get server02 to obtain an address via DHCP (also running on the RRAS SERVER01 box) they seem to bypass that and end up getting an address from the router. If I configure static addresses everything seems to work ok. Is there a way to block DHCP requests from being routed from LAN to Internet or should I have my RRAS configured differently?

All boxes are running Server 2003 SP2. ESXi has single NIC and is version 4.0.0

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Terribly terribly stupid of me. Feel like an utter fool, perhaps a break from this is in order.

All seems to work now that I have authorised my DHCP server to give addresses!

Sorry if I have wasted anyones time.

share|improve this answer
2  
Not a waste of time from my perspective. It sounds like you're right on track as far as "learning by doing" is concerned... so pretty smart after all. Carry on. ;) –  joeqwerty Jul 5 '11 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.