Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem with simultaneously running KVM instances whose nature I can really only describe as interference. When I run one virtual machine alone I have no difficulty interacting with it, either through the sdl console presented or via ssh. However, once I run two virtual machines I am unable to:

  • login at the sdl console; the correct username/password being declared invalid on the first attempt and further attmepts echoing text I have not typed, such as "r^]o^]o^]t^]"
  • finalize the ssh connection into an affected instance

My client machines are Debian Squeeze and my host machine is Arch Linux 2.6.39-ARCH with qemu-kvm 0.14.1. Here's how I'm running the two interfering virtual machines:

#!/bin/sh

for f in puppet loadbalance # app0 db_master0 db_slave0 jenkins
do
    qemu-kvm -drive file=$f.qcow2,if=virtio -boot c -netdev type=vde,id=tiny \
        -device virtio-net-pci,netdev=tiny -name $f &
done

If I run the machines with the -nographic flag I am able to complete an ssh login, but eventually (within 5 minutes) all but one ssh console experiences very high latency. Once "focused" that virtual machine responds immediately, while the others become high-latency. Pings around the virtual network fail, between the "focused" machine and all others and from my host. What's going on here?

share|improve this question
1  
Have you checked that the VM's are given unique MAC addresses? –  Nick Adams Jul 5 '11 at 22:51
    
You're quite correct: I was neglecting the macaddr. If you will provide an answer I'd happily accept it. That does not solve the sdl interference problem, but it's close enough for jazz. –  troutwine Jul 7 '11 at 1:59

2 Answers 2

up vote 1 down vote accepted

Check that instances all have unique MAC addresses. Sounds as though there is a MAC address collision issue.

share|improve this answer

-netdev tap,fd=21,id=hostnet0,vhost=on,vhostfd=23 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:87:ec:d3,bus=pci.0,addr=0x3

this is what I use for networking. Can't see why you'd want to use vde, when bridging works so well. Especially, since it's not recommended for QEMU anyway:

VDE The VDE networking backend uses the Virtual Distributed Ethernet infrastructure to network guests. Unless you specifically know that you want to use VDE, it is probably not the best backend to use.

prooflink: http://wiki.qemu.org/Documentation/Networking#VDE

share|improve this answer
    
Thank you for your contribution. –  troutwine Jul 7 '11 at 2:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.