Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After i was told by my server providers support staff to swtich to FastCGI from Apache php support, i later found out that mod_deflate stopped working, it was working fine before the switch. My static files were delivered without being gzipped. I did a grep via ssh for mod_deflate in my httpd.conf and the module wasn't commented out.

I was advised to make the switch because of permission errors on my WordPress install. All my plugins were creating files/folders that were owned by apache. I'm not sure if this was the proper course of action, it definitely solved the permission problems, and all files/folders which are created now are owned by my ftp user.

I'd rather stick to what I've got configured on my vps instead of moving to things such as php-fpm, any suggestions on how to resolve this problem internally?

Thanks in advance.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I seem to have solved the problem. The problem was that AddOutputFilterByType was wrapped around <IfModule mod_filter.c> in my .htaccess file, which worked when i was using Apache php support.

I'm really not sure how these modules are loaded on specific circumstances. Perhaps someone can explain to me what just happened through the comments? Thanks!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.