Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting the folling error message when I try to use the 'setup' application on CentOS 5.5 to configure the Apache webserver.

bash: setup: command not found

However, when I tried to install it with:

yum install setup

I got the response that it was already installed and no work need to be done.

I'm logged in as root.

Any idea what the problem could be?

Many thanks

share|improve this question

migrated from stackoverflow.com Jul 6 '11 at 15:13

This question came from our site for professional and enthusiast programmers.

    
a program can very well be installed yet not in one of the directories in the path. –  fvu Jul 5 '11 at 22:01
    
I have tried to use the 'find' command to look for the setup file or directory, but it can't find it anywhere on the computer. –  Joe Jul 5 '11 at 22:39
1  
Thanks for the tip about using the rpm command to query. Very useful. In the end I found out what I needed to install was an application / utility called 'setuptool' which allows you to configure various things such as the firewall etc. Thanks for your help. –  Joe Jul 6 '11 at 8:17
    
you're welcome, good luck with the new server –  fvu Jul 6 '11 at 8:24

2 Answers 2

up vote 2 down vote accepted

In case anyone else stumbles across this question, I thought I'd provide a bit of an explanation here even though it sounds like the OP is all set:

When you install a package using yum, as in:

yum install setup

You're installing a package called setup. This does not necessarily mean you're installing an application of the same name. In this case, setup is simply a low-level package that installs some necessary system configuration files. You can see the complete contents of the package like this:

rpm -ql setup

And you can get more information about the package like this:

rpm -qi setup

This includes a description of the package:

The setup package contains a set of important system configuration and setup files, such as passwd, group, and profile.

If you want to install a particular application, you can try searching for it with yum search, or if you know a particular binary name you can usually provide that as an argument to yum install. For example:

yum install /bin/zsh

You can work backwards and figure out what packages owns a particular file like this:

rpm -qf /path/to/some/file

For example:

# rpm -qf /usr/bin/ssh
openssh-clients-5.6p1-31.fc15.1.x86_64
share|improve this answer

May be you are looking for setuptool package

yum install setuptool

setuptool package will provide setup command for centos , fedora ,redhat & most of the rpm based distros.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.