Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently enabled VPN connections to my Windows Server 2008 R2 box, and even though I can connect to it just fine from Windows 7, I am unable to access anything on the network via its intranet domain name. Ideally I would like to access these resources without having to use a FQN. What steps can I go through to check on Windows 7 why I cannot use my DNS server's domain names from across the VPN? The DNS suffix for the VPN connection isn't being specified in my list of DNS suffixes when I do ipconfig /all

I apologize for being so vague, so if there is additional information I can provide, please let me know and I will provide it in an edit or through comments.

share|improve this question

closed as off topic by EEAA, sysadmin1138 Jan 19 '12 at 3:39

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Home networks are out of scope for the FAQ. This is for professional workplace items. – sysadmin1138 Jan 19 '12 at 3:39
up vote 3 down vote accepted

What kind of machine do you use to provide DHCP addresses? In general, you can specify DHCP options 15 (DNS domain suffix) and 119 (DNS domain search list) to automatically populate these values in most clients. Here's how to do it on a Windows DHCP server; if you're using something else, you can find instructions for configuring those options online.

share|improve this answer
For VPN connections, my Windows Server acts as a DHCP server and provides a limited range of IPs to clients. I'm not sure what the codes you speak of are. How do I configure my server in the way you are describing? Thanks. – void.pointer Jul 7 '11 at 13:44
The link I provided (…) has instructions for doing so. – Handyman5 Jul 7 '11 at 15:26
Oh thanks. The link color blends too much into the text so I missed it. – void.pointer Jul 7 '11 at 15:43
I'm using Windows Server 2008 R2 and I do not have DHCP under Administrative Tools. Doing a bit of reading, I find that I am not able to set these DHCP options. The article you linked is for "Communications Server 2007", which I am not using. – void.pointer Jul 13 '11 at 21:25
Forgive me, I did not realize that option 119 is not one of the predefined options. You can follow these steps to add 119 as a new predefined option, after which you'll be able to set it through the GUI. – Handyman5 Jul 13 '11 at 22:19

If you aren't interested in using the FQDN. You can setup your hosts record in c:\windows\system32\drivers\etc\hosts

share|improve this answer
There has to be a more streamlined way of setting this up. I don't want to touch my hosts file, I don't even want to explicitly configure my DNS suffix search list from my network connection properties. – void.pointer Jul 6 '11 at 19:06
While using the hosts file will work it's almost always the worst possible solution. High maintenance, error prone and the cause of more networking woes than anything else I can think of. – John Gardeniers Jul 6 '11 at 22:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.