Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I created a proxy by creating a SSH tunnel using PUTTY, and then filling in the values of the server in my home computer's browser proxy settings. I entered the server IP in the Socks list.

I can view all HTTP non secure sites, but when I try to go to a HTTPS site, the page comes out blank. Happens with all HTTPS sites.

Whilst connecting by putty, I even tried putting local port 443 and destination port localhost:443, and filling in the browser proxy settings for the HTTPS field, but no luck still.

Can anybody tell me how I can achieve to browser HTTPS using my proxy.

share|improve this question
    
are you sure the host you're opening the SSH tunnel to is allowed to access https sites or more correctly can access a service on Port 443? –  Marcel G Jul 6 '11 at 20:55
    
which browser are you using to access https pages? –  ghm1014 Jul 6 '11 at 21:30
    
PuTTY creates and SSL tunnel, not a proxy. Can you clarify your setup a bit. When you say server do you mean the server you ssh'd to or the one your trying to browse to? –  David Jul 7 '11 at 3:12
    
@Marcel G Sorry, I asked that question without registering here, and I can't seem to comment on it now. Anyway, created user and here I am again. The server I am tunneling to is a web server that has access to https sites. I can SSH into the server, and when I do something like telnet www.google.com 443 it says Connection Established @gmh1014 I tried in firefox, IE8, and Chrome. None of them working for HTTPS sites @David I am creating a SSH Tunnel between my home computer and my VPS server, and am accessing the internet through my server using that Tunnel. –  NetworkNewbie Jul 7 '11 at 5:08
    
David: that's what I used to think, too, and then I was gently and courteously pointed to the -D flag for ssh. Have a look at the man page! –  MadHatter Jul 7 '11 at 6:03

2 Answers 2

The server IP shouldn't be listed as your proxy if you're using ssh with -D (or equivalent). In fact, I'm surprised it works at all! When configuring ssh for SOCKS mode, you tell it a port number (in cli ssh you would do "ssh -D somenum username@server") that is the local port. So your SOCKS settings should point to localhost:that-port.

share|improve this answer

A tunnel (port forwarding, really) is not a proxy per se; but, as MadHatter pointed out, ssh can act as a SOCKS proxy server if so instructed. Not sure about PuTTY.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.