Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a few Dell 6224 and a bunch of 3524's and some 5324 - with the latest firmware.

I need to configure QinQ between ports, conveniently called "Customer port" on the 35xx and the 53xx, and it works like a charm there, can even do the config right from gui - set the port to customer mode, and tag the vlan to use for the transport. (ingress data tag data is ignored and a outer heading added for transport, egress strips the outer tag).

But, the 62xx will not play nicely - it has what is called "double-vlan" or dvlan-tunnel, which is supposed to provide the same features. The manual is junk and support havent provided an answer in days now. The best online info I could find was at http://en.community.dell.com/support-forums/network-switches/f/866/p/19265885/19563705.aspx but that still doesnt tell me the correct way of using dv-lan tunnel - as soon as I enable it on any interface, all other trunks stops forwarding.

Does anyone know how to configure this correctly without bringing down the rest of the switch, when you have a mix of normal q-tags and need some q-in-q for just a port or two?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

The 'mode dvlan-tunnel' option on the 62xx switches does work, but it's "backwards". You enable the 'mode dvlan-tunnel' option not (as one would expect) on push/pop ports, but instead on all trunks that will carry your provider tags. Then you set your customer-facing push/pop ports as standard access ports with the access vlan of your provider (outer) tag, and let customers do their thing within.

share|improve this answer
    
wow - so there is no way to configure without downtime unless I had set it on all regular trunks from the beginning.. heh.. what a wonderful world - Dell really should stick to one OS when it comes to its switches... thank you –  Stokkeland Jul 7 '11 at 15:16
    
btw that did work just fine - and looking at the original URL it was right in there, the answer was too complicated on that page for my farted out brain to get :) I don't know why that wouldn't be a default option on all trunk ports then, and to explicitly turn it off for "customer ports"... oh well, Dell works in mysterious ways –  Stokkeland Jul 7 '11 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.