Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This question already has an answer here:

So I tried to change my mysql root password for the first time using a advanced pattern and it looks like phpmyadmin stripped the password on save. Now I can't login under root.

I am using RHEL 5 and it seems that all the instructions I keep finding don't work.

When I run the following command. I get

[root@vault ~]# mysqld_safe –skip-grant-tables -u root &
[1] 30274
[root@vault ~]# Starting mysqld daemon with databases from /var/lib/mysql
STOPPING server from pid file /var/run/mysqld/mysqld.pid
110705 20:38:37  mysqld ended

Does anyone know of a workaround that works?

Thanks,

share|improve this question

migrated from stackoverflow.com Jul 7 '11 at 1:09

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Chris S Mar 20 '13 at 5:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Can you post the tail of the MySQL error log? On Ubuntu this will do it - not sure if RHEL puts it in the same place: tail /var/log/mysql.err –  ratsbane Jul 6 '11 at 2:17

2 Answers 2

up vote 2 down vote accepted

You have a typo

mysqld_safe –skip-grant-tables -u root &

should read

mysqld_safe -–skip-grant-tables -u root &
share|improve this answer

Recently addressed:

Lost MySQL password

If the --skip-grant-tables doesn't work as a flag, see above link.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.