Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to run activemq as a service on my windows7 machine, service install properly, but it does not start as LocalSystem account. It works perfectly if I start it with logon property as my user. Unfortunately there is nothing in the log file ( it is actually not created if I start as LocalSystem). Binary msmq files are located under Program Files, can this be a problem too ?

Thanks for any advice,

Felice

share|improve this question
    
Working on the same problem right now. My guess is it has something to do with persistence. Are you using the default KahaDB configuration? –  joshua.ewer Aug 10 '11 at 19:02

1 Answer 1

up vote 1 down vote accepted

Your issue is that the local system account doesn't have rights to create temp directories. So, if you want to use the local system account, you can explicitly set the java.io.tmpdir property in the wrapper conf to a location that the local system has rights to.

As an example, this is my dev setting (in %ACTIVEMQ_HOME%/bin/win32/wrapper.conf):

wrapper.java.additional.10=-Djava.io.tmpdir="%ACTIVEMQ_BASE%"/temp
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.