Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having trouble setting up a nameserver for my domain, we recently changed the nameserver of my domain because of an application that said our nameservers were not working fine. But now my domain does not respond to requests. I have no idea what were the last nameservers that were working. My domain is registered on Go Daddy, I did try to register my domain name to nameservers from zoneedit.com wich they say my domain has been correctly added to these nameservers : NS1.NAMERESOLVE.COM, NS2.NAMERESOLVE.COM, NS3.NAMERESOLVE.COM, NS4.NAMERESOLVE.COM which i put in Go Daddy nameserver setup. When i use intoDNS.com to check on my domain, i get 2 errors (which is a lot less than before, i use to have errors about the nameservers) :

MX - MX Records : Oh well, I did not detect any MX records so you probably don't have any and if you know you should have then they may be missing at your nameservers!

WWW - WWW A Record ERROR: I could not get any A records for www.datahex.ca!

(I only do a cache request, if you recently added a WWW A record, it might not show up here.)

An other thing is that my domain actually work for half my clients. My emails are not working.

So how can I fix this?

My domain is datahex.ca I do have an other domain called datahex.com which works fine and is the same website and ip adresse has datahex.ca but is nameservers don't work with my other domain.

thank you.

Here is what i can do in dns manager on zoneedit.

DNS Management help

datahex.ca     A     69.70.171.98        Delete   

Sub Domain Priority Mail Server / MX
datahex.ca
Only enter data in the ____ (Add new MX record) first field if you
need a MX record for a sub domain.

Sub Domain CName Server
datahex.ca _____ (Add new CNAME record) Only enter data in the first field if you
need a CNAME record for a sub domain.

Sub Domain IP Address / A
datahex.ca _____ (Add new A record)

Only enter data in the first field if you need a A record for a sub domain.

Sub Domain Text Record / TXT
datahex.ca _______ (Add new TXT record)

Only enter data in the first field if you need a TXT record for a sub domain.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need to create an A record for www if you want users to be able to get to www.datahex.ca and you need to create an MX record if you want users to be able to send you email. Your current name servers have neither.

In addition, you can create an A record for the domain itself as it also currently doesn't have one.

This information was obtained by querying ns1 - ns4.nameresolve.com directly.

share|improve this answer
    
Thank you for the quick answer, I know that I have to add an A record and mx record but when I did on the nameservers it simply didn't do a thing. how can i create an a record dirrectly on a domain? On Go Daddy settings? And how did you query ns1 - ns4 directly? I know tracert and nslookup but it didn't tell me any of that. –  Azshlanar Jul 7 '11 at 18:15
    
You have to add the records at the name servers for the domain, which are ns1 - ns4.nameresolve.com. Presumably you have access to a DNS control panel of some type at nameresolve.com (Dotster). GoDaddy is the registrar for your domain and lists your name servers primarily for WHOIS lookups, but your name servers have been moved to nameresolve.com so that's where you need to set up the DNS records. I queried those name servers directly by using nslookup with the command: server ns1.nameresolve.com, server ns2.nameresolve.com, etc. and then querying those servers for the appropriate records. –  joeqwerty Jul 7 '11 at 18:41
    
here is what i added in dns manager of zoneedit.com (added in question). But It dosen't seem to be doing anything. Maybe i'm understanding this the wrong way... –  Azshlanar Jul 7 '11 at 19:43
    
okay, my only problem now is that www.datahex.ca does not work but datahex.ca does! I did switch www from A records to CNAME. In my host file am I suppose to put the internal adresse or the public one? This is what my hosts look like: 192.168.200.11 www.datahex.ca 192.168.200.11 datahex.ca 127.0.0.1 localhost ::1 localhost –  Azshlanar Jul 7 '11 at 23:21
    
You need to add the public ip address not the private ip address. –  joeqwerty Jul 7 '11 at 23:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.