Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Debian 5 + Plesk 9.5.4 installation on my server, and just installed Nagios3 via apt-get. I have set up a subdomain on my virtualhost, with cgi support in Plesk, and then copied any nagios cgi to that new directory, setting that cgi files' owner to my subdomain's FTP user and group. Now, accessing to http://subdomain.mydomain.com/nagios3/ I can see my nagios main menu, docs etc., but accessing to any cgi from nagios menu, I always see this CGI error message:

Whoops!

Error: Could not read object configuration data!

Here are some things you should check in order to resolve this error:

    Verify configuration options using the -v command-line option to check for errors.
    Check the Nagios log file for messages relating to startup or status data errors. 

Make sure you read the documentation on installing, configuring and running Nagios thoroughly before continuing. If all else fails, try sending a message to one of the mailing lists. More information can be found at http://www.nagios.org. 

Checking nagios configuration with -v command line option was successful. I know Plesk's apache runs CGIs with suexec, so I seen "uid: (10011/nagiosweb) gid: (110/110) cmd: config.cgi" in my /var/log/apache2/suexec.log, and also changed /etc/nagios3/conf.d/* and /etc/nagios3/*.cfg owner user to "nagiosweb", which is my subdomain's FTP user as set in Plesk.

Any suggestion? Thanks in advance... :)

P.S. I can correctly see my nagios web interface and associated CGIs accessing via lynx to http://localhost/nagios3/ !

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Error: Could not read object configuration data

I seen "uid: (10011/nagiosweb) gid: (110/110) cmd: config.cgi" in my /var/log/apache2/suexec.log, and also changed /etc/nagios3/conf.d/* and /etc/nagios3/*.cfg owner user to "nagiosweb"

How about the object configuration files:

chown -R nagiosweb /etc/nagios3/objects
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.