Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Website(s) were up. I changed my config files in sites-enabled, then ran:

apache2ctl configtest

Got: Syntax OK

Then ran:

apache2ctl graceful

Got returned to the command prompt. No messages. The websites went down, did not restart. Also, I wasn't prompted for a passphrase which I should have been since my key has it.

So I put back the old configs (quickly) and restarted.

Does apache2ctl graceful not support the passphrase ? No error messages were in error.log files. Just "[notice] Graceful restart requested, doing restart", then nothing.

UPDATE 7/8 : After searching other error logs (previously just checked main one), I found this:

SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
share|improve this question
FYI: I've now removed the passphrase from my key, but don't really want to experiment with my live server (no qa box at the moment). So hoping someone can shed some light here before I try again. – Fraggle Jul 8 '11 at 1:51
This is the first time I've tried to configure for SSL on my server. I added a VirtualHost *:443 section and changed others to VirtualHost *:80, added a NameVirtualHost *:80 and NameVirtualHost *:443 – Fraggle Jul 8 '11 at 1:53
Found the answer. Wrong key file. See my comments below. – Fraggle Jul 8 '11 at 5:40
There's a related post at: – Pacerier Apr 15 at 18:01

Do a full restart, not a graceful one. Your change to have the private key unencrypted should also work.

Conceptually, I can't imagine the apachectl process being able to prompt for a new passphrase for a startup when the main process is only being sent signals by apachectl, not being spawned by it.

In more concrete terms - this 7-year-old posting on a bug report confirms that the behavior that you're seeing is expected - sorry, couldn't find anything more recent confirming that the issue still exists in current apache versions, but it fits.

share|improve this answer
So do apache2ctl stop, then apache2ctl start? What is the correct way to start without using apache2ctl. Apache docs do not have it that I can see. – Fraggle Jul 8 '11 at 4:22
apache2ctl restart should do the trick. The "right" way depends on your OS and how Apache's set up - might be init scripts, or the service command. – Shane Madden Jul 8 '11 at 4:26
I've tried again. Put my ssl configs back in place, tried apache2ctl stop, followed by apache2ctl start. Well the stop sure works, but start does nothing. Nothing in error log. Just returns to command prompt and websites are down. Is there some kind of delay when starting with ssl?? – Fraggle Jul 8 '11 at 4:52
UPDATE: after more thourough searching of all error logs, I found this: "SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch" – Fraggle Jul 8 '11 at 5:08
Ok, found the answer. All my fault. Wrong key file. Dumb mistake. Had one from a few months ago that I never used. Also missed error message cause it was in a different error log than I checked. Bad mistakes. – Fraggle Jul 8 '11 at 5:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.