Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using Windows 7, Python 2.7.2.

Before the problem occured, I've been writing code in IDLE(Python GUI) for 30 min and everything's fine.

Then I went into "IDLE configuration" and changed the settings to the following states: 1) When press F5, don't show the prompt "save or not'. 2) Upon start, show editor(instead of shell);

Then I close IDLE, and clicked the IDLE(Python GUI) icon(from the start menu), and no window pops up...

However, I can start "Python(command line)" without any problem.

Have tried uninstall - reboot - reinstall(both python 2.7 AND 3.2 had been tried), but the problem persists.

Any ideas why this happened?

share|improve this question
add comment

migrated from stackoverflow.com Jul 8 '11 at 21:02

This question came from our site for professional and enthusiast programmers.

4 Answers

up vote 2 down vote accepted

Try deleting the contents of the .idlerc folder in your profile. To open the folder just type <winkey-r> and enter %USERPROFILE%\.idlerc.

share|improve this answer
    
Yeah, this solution worked perfectly! Thanks! –  asunnysunday Jul 9 '11 at 6:24
    
But do you have any ideas why the problem occurred? I applied the configuration again: 1) When press F5, don't show the prompt "save or not'. 2) Upon start, show editor(instead of shell); then I restarted, and it worked like charm. But why this happened? –  asunnysunday Jul 9 '11 at 6:27
    
@asunnysunday, I think maybe you crossed the streams and overloaded the flux capacitor before engaging the transwarp drive in your TARDIS... Sorry, but I don't really know. I guess either the configuration file wasn't saved properly or its security metadata made it inaccessible (wrong owner, read-only, etc). I don't think it's worth a full forensic analysis. Make a backup of the configuration file, and just restore the backup if the problem comes back. –  eryksun Jul 9 '11 at 6:44
    
God, I spent a minute looking up the alien words in your first sentence, and eventually I, a ESL guy, understood that it's a joke, HaHa! Thanks a lot for your advice! BTW, is "forensic analysis" a common US idiom to refer to rigorous investigation(though not in a law context)? Or your using it here isn't very "legal"?~~ –  asunnysunday Jul 9 '11 at 8:26
1  
@tq: Windows Explorer should automatically expand that and open .idlerc, if it exists. –  eryksun Oct 15 '12 at 13:25
show 4 more comments

Try running this from the command line:

c:\Python27\Lib\idlelib\idle.bat

Do you see any errors?

Now try this:

c:\Python27\python.exe c:\Python27\Lib\idlelib\idle.pyw

Do you see any errors?

share|improve this answer
add comment

The reason why IDLE no longer starts is like related to the bug report here: http://bugs.python.org/issue13582

IDLE is having trouble processing one of your configuration files in ~/.idlerc. If you post the error message you see when running "python -m idlelib.idle", I can tell you how to fix it.

share|improve this answer
add comment

I'm not sure if this is your issue, but when my IDLE stopped appearing, I found that disabling UAC (user account control) helped fix the issue. Try opening IDLE as an administrator, and see if that helps fix your problem.

Also, eryksun's suggestion may help as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.