Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm installing Dovecot 2.0 and I am running into problems with it checking for new messages. Postfix is getting the messages but dovecot is not finding them.

In my dovecot.conf I am using a static userdb which checks my passdb using sql. When I start dovecot the log says it starts without error but does not mention anything about auth-worker connecting to my database. Looking at dovecot -n I can see that it is still trying to use PAM to authenticate despite it being commented out in the log:

passdb {
  driver = pam
}
ssl_cert = </etc/ssl/certs/dovecot.pem
ssl_key = </etc/ssl/private/dovecot.pem
userdb {
  driver = passwd
}

No errors show up on the log right away but there are occasional errors that look like this:

localhost dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=22714, input bytes=0
localhost dovecot: auth: Fatal: Support not compiled in for passdb driver 'pam'
localhost dovecot: master: Error: service(auth): command startup failed, throttling

I pastebinned the full log here: http://pastebin.com/c0VtFt2n

share|improve this question

1 Answer 1

up vote 0 down vote accepted

In dovecot 2 the configuration files aren't the same - the values from your dovecot.conf file are probably being over-written. (Most online articles are written for dovecot 1.x, so be careful - go straight to the dovecot site for information, or ensure you have instructions specific for dovecot 2).

Check the conf.d directory (usually /etc/dovecot/conf.d, but might depend on how you installed) for the rest of the configuration files. PAM authentication is (I believe) in auth-system.conf.ext.

As you have noted, dovecot -n gives you the configuration dovecot reads. If you need to see a list of all settings, include the defaults, run dovecot -a.

share|improve this answer
    
I have a conf.d directory but it is empty. I tried copying the files in and reloading but it made no difference. I noticed dovecot -n lists my config being loaded from /usr/local/etc/dovecot/dovecot.conf. I don't think the log is being loaded at all because I've turned on all the addition logging options and there is no change. –  devnill Jul 10 '11 at 7:03
    
a) did you check /usr/local/etc/dovecot/conf.d? b) You say that 'dovecot lists your config being loaded from...' is that the file you have been editing? c) Did you install by compiling or from a package manager? d) check which config is actually passed to dovecot in your init script (/etc/init.d/dovecot on some operating systems - around line 38 on the default script there is a line starting with 'config =' e) it would be helpful if you posted the output of dovecot -n f) once you confirm the config files being used, you will want to start simple and add (e.g. ssl) to the setup step by step –  cyberx86 Jul 10 '11 at 7:22
    
Found it! I totally didn't notice the config was in local. Thanks! –  devnill Jul 10 '11 at 21:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.