Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've used the stasadm -o backup/restore commands to migrate a site collection to a new URL.

The new site seems to be working fine, with one exception. Document libraries that contain folders don't work properly.

I'm able to access the library, but clicking on a folder within the library just sends me to a generic error page with the unhelpful message "Cannot complete this action." I can't create new folders within the library either.

Anyone else run into this behavior?

share|improve this question
    
Can you look in the event log and also in the sharepoint log files and provide any additional clues as to what is happening when you try to drill down into the folder? –  Aaron Weiker Jun 20 '09 at 5:43

2 Answers 2

I agree with Aaron's comment above -- additional information would be helpful. Barring more information, though, here are a couple of high-level checks you can do:

  1. When you restored the site collection, did you do so into the same farm? If you went between farms, do they line-up in terms of service packs and hotfix levels? Differing patch levels between source and destination have been known to cause issues.

  2. Assuming you're simply moving to a different web application within the same farm, examine the Feature sets that are activated. Is there a chance that the site collection (or web housing the document library) was leveraging a Feature that isn't active or deployed to the new web application? To the site collection in its new home?

For what it's worth!

share|improve this answer
    
+1 for the patch levels. This is exstremely crucial if you are moving data between farms. –  Aaron Weiker Jun 26 '09 at 15:31

I'm sure this problem is long solved, but I wanted to post this for anyone else looking at a similar issue.

My problem was that when I was mapping my url, the port was dropping off in the document section. I extended the mapping and it solved the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.