Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got a couple local repositories that I can successfully access using Apache WebDav.

This apache is also a production webserver and I've got directory listings disabled globally.

Here's the Location config:

<Location /svn>
   DAV svn
   SVNParentPath /var/local/svn
   SSLRequireSSL
   AuthType Basic
   AuthName "Dining Deals Network SVN"
   AuthUserFile /var/local/users/svn.passwd
   Require valid-user
</Location>

We have 2 repo's in /var/local/svn. Right now, you have to navigate to them directly. If you just go to https://www.ourdomain.com/svn you get a

(403) Forbidden

You don't have permission to access /svn/ on this server.

I've tried adding a (and i've also tried a just for kicks) with an Options Indexes but it didn't accomplish anything.

Any help would be appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Somehow I overlooked this in the SVN WebDav documentation:

http://svnbook.red-bean.com/en/1.5/svn.ref.mod_dav_svn.conf.html

The directive is:

SVNListParentPath On|Off

When set to On, allows a GET of SVNParentPath, which results in a listing of all repositories under that path. The default setting is Off.

I knew I'd seen this working before. But GHM thanks for trying to help, you're the only one that did!

share|improve this answer

I think you cannot access ParentPath since it is not an SVN directory, so it won't match SVN permissions. What I did in order to navigate SVN repositories is to install WebSVN. I installed it by yum (for redhat/fedora) but you can use the standard installer. It's simple to install and to use, also uses the same password an auth file than SVN so you don't need any additional authentication users.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.